Bug 8956

Summary: Pine Hardcodes "APPLICATION/MSWORD" mime type and can get it wrong
Product: [Retired] Red Hat Linux Reporter: tibor
Component: pineAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-04-27 15:33:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description tibor 2000-01-29 01:59:25 UTC
Instead of relying solely on a mime.types file, pine 4.10 (in
./pine/send.c, around line 6910) looks at the first few bytes of an
attachment to determine its type.  I've had several MS Excel 97 files which
pine 4.10 slaps an "APPLICATION/MSWORD" mime type onto, which can mess up
the recipient's ability to view the attachment directly from his/her MUA
(in two cases of mine the recipients were using Netscape 4.61/win95 and MS
Outlook/WinNT).

I don't know what the "correct" fix is, but in my case changing the subtype
from "MSWORD" to "octet-stream" took care of it.  I've sent email to
pine-info@u.washington.edu but haven't received anything back.

Comment 1 Trond Eivind Glomsrxd 2000-04-07 19:57:59 UTC
Does the 4.21 shipped with 6.2 have the problem? Could you attach a file which
demonstrates the problem?

Comment 2 Trond Eivind Glomsrxd 2000-04-27 15:33:59 UTC
I can't reproduce it with the version shipped with 6.2