This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 895741

Summary: TypeError: not enough arguments for format string
Product: [Fedora] Fedora Reporter: Andrew McNabb <amcnabb>
Component: yumAssignee: packaging-team-maint
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: admiller, ffesti, g.kaviyarasu, jonathan, packaging-team-maint, sbueno, tla, vanmeeuwen+fedora, zpavlas
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:e534de7fc8bd341d9487ffca14463d6ed003f8a7b7d8d80709ee5b34887da0f7
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-16 09:04:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: anaconda-tb
none
File: anaconda.log
none
File: environ
none
File: ifcfg.log
none
File: ks.cfg
none
File: packaging.log
none
File: program.log
none
File: storage.log
none
File: syslog none

Description Andrew McNabb 2013-01-15 17:06:39 EST
Description of problem:
The installer crashed soon after starting up. It was running from a kickstart script.
The following was filed automatically by anaconda:
anaconda 18.37.11 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/logging/__init__.py", line 328, in getMessage
    msg = msg % self.args
  File "/usr/lib64/python2.7/logging/__init__.py", line 464, in format
    record.message = record.getMessage()
  File "/usr/lib64/python2.7/logging/__init__.py", line 723, in format
    return fmt.format(record)
  File "/usr/lib64/python2.7/logging/handlers.py", line 791, in emit
    msg = self.format(record) + '\000'
  File "/usr/lib64/python2.7/site-packages/pyanaconda/anaconda_log.py", line 114, in emit
    SysLogHandler.emit(self, record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 748, in handle
    self.emit(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1308, in callHandlers
    hdlr.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1268, in handle
    self.callHandlers(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1258, in _log
    self.handle(record)
  File "/usr/lib64/python2.7/logging/__init__.py", line 1184, in critical
    self._log(CRITICAL, msg, args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3693, in selectGroup
    self.logger.critical(_('Group %s does have %u conditional packages, which may get installed.'), count_cond_test)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1070, in _selectYumGroup
    self._yum.selectGroup(groupid, group_package_types=pkg_types)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1198, in _applyYumSelections
    self._selectYumGroup(group.name, default=default, optional=optional)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1229, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1316, in preInstall
    self.checkSoftwareSelection()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 124, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups(ksdata.lang.lang))
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: not enough arguments for format string

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=f18-x86_64/initrd.img repo=http://mirrors.cs.byu.edu/fedora/releases/18/Fedora/x86_64/os ks=http://aml.cs.byu.edu/install/f18.ks ksdevice=bootif biosdevname=0 sshd BOOTIF=01-22-22-22-22-22-22 BOOT_IMAGE=f18-x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: 
package:        anaconda-18.37.11
product:        Fedora
release:        Cannot get release name.
type:           libreport
version:        18
Comment 1 Andrew McNabb 2013-01-15 17:06:42 EST
Created attachment 679116 [details]
File: anaconda-tb
Comment 2 Andrew McNabb 2013-01-15 17:06:44 EST
Created attachment 679117 [details]
File: anaconda.log
Comment 3 Andrew McNabb 2013-01-15 17:06:46 EST
Created attachment 679118 [details]
File: environ
Comment 4 Andrew McNabb 2013-01-15 17:06:48 EST
Created attachment 679119 [details]
File: ifcfg.log
Comment 5 Andrew McNabb 2013-01-15 17:06:49 EST
Created attachment 679120 [details]
File: ks.cfg
Comment 6 Andrew McNabb 2013-01-15 17:06:51 EST
Created attachment 679121 [details]
File: packaging.log
Comment 7 Andrew McNabb 2013-01-15 17:06:53 EST
Created attachment 679122 [details]
File: program.log
Comment 8 Andrew McNabb 2013-01-15 17:06:55 EST
Created attachment 679123 [details]
File: storage.log
Comment 9 Andrew McNabb 2013-01-15 17:06:58 EST
Created attachment 679124 [details]
File: syslog
Comment 10 Andrew McNabb 2013-01-15 17:12:57 EST
The crash occurred while the progress bar read "Starting package installation process". After rebooting and trying again, the same error occurred at the same point.
Comment 11 Chris Lumens 2013-01-15 17:15:46 EST
Note the line in the middle of the traceback:

  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3693, in selectGroup
    self.logger.critical(_('Group %s does have %u conditional packages, which may get installed.'), count_cond_test)
Comment 12 Andrew McNabb 2013-01-15 18:01:36 EST
I adjusted my package groups in response to Comment 11, and it looks like commenting out deprecated package groups may have helped to work around the issue. I haven't specifically tried adding them in one by one, but it might help anyone who's trying to reproduce the issue to add any of: base, graphical-internet, graphics, java, java-development, office, sound-and-video, system-tools, or text-internet, all of which are now commented out.
Comment 13 Zdeněk Pavlas 2013-01-16 09:04:12 EST

*** This bug has been marked as a duplicate of bug 885139 ***