Bug 896157

Summary: Update client library/commandline from upstream stable branches and selected backports from Grizzly
Product: Red Hat OpenStack Reporter: Perry Myers <pmyers>
Component: python-keystoneclientAssignee: Alan Pevec <apevec>
Status: CLOSED ERRATA QA Contact: Pavel Sedlák <psedlak>
Severity: medium Docs Contact:
Priority: high    
Version: 2.0 (Folsom)CC: ayoung, jhenner, jpichon, kchamart
Target Milestone: snapshot3Keywords: Rebase, Triaged
Target Release: 2.1   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: python-keystoneclient-0.2.0-1.el6ost Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-21 15:04:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 892320, 912847    

Description Perry Myers 2013-01-16 13:34:54 EST
Update client library/commandline from upstream stable branches and selected backports from Grizzly
Comment 1 Julie Pichon 2013-02-04 07:57:12 EST
For the keystone client, we should try to rebase to version 0.2.0 or backport https://github.com/openstack/python-keystoneclient/commit/0dfc69806d3767a7f6be91d9df18f20d31866c91, to fix bug 892320 and avoid misleading error messages in the Horizon logs.
Comment 2 Alan Pevec 2013-02-11 12:54:17 EST
stable/folsom "upstream" proposal
https://github.com/fedora-openstack/python-keystoneclient/commits/stable/folsom

* based on 0.2.0 (0.2.1 introduced python-requests dependency) with post-Folsom features (v3 and authtoken mw in client) reverted

We'll see how that goes.
Comment 4 Kashyap Chamarthy 2013-02-26 02:32:20 EST
VERIFIED.

#---------------------------#
[tuser1@interceptor export(keystone_user1)]$ cat /etc/redhat-release ; arch
Red Hat Enterprise Linux Server release 6.4 (Santiago)
x86_64
[tuser1@interceptor export(keystone_user1)]$ 
#---------------------------#
[tuser1@interceptor export(keystone_user1)]$ rpm -q python-keystoneclient
python-keystoneclient-0.2.0-1.el6ost.noarch
[tuser1@interceptor export(keystone_user1)]$ 
#---------------------------#


Verification Info:

Get the SRPM; extract it; find path to sources using 'spectool'

#---------------------------#
[tuser1@interceptor export(keystone_user1)]$ wget http://download.devel.redhat.com/brewroot/packages/python-keystoneclient/0.2.0/1.el6ost/src/python-keystoneclient-0.2.0-1.el6ost.src.rpm
#---------------------------#
[tuser1@interceptor export(keystone_user1)]$ rpm2cpio python-keystoneclient-0.2.0-1.el6ost.src.rpm| cpio -idmv
0001-remove-post-Folsom-features-in-keystoneclient.patch
python-keystoneclient-0.2.0.tar.gz
python-keystoneclient.spec
430 blocks
[tuser1@interceptor export(keystone_user1)]$ 
#---------------------------#
[tuser1@interceptor export(keystone_user1)]$ spectool --sources python-keystoneclient.spec 
Source0: http://pypi.python.org/packages/source/p/python-keystoneclient/python-keystoneclient-0.2.0.tar.gz
[tuser1@interceptor export(keystone_user1)]$ 
#---------------------------#
Comment 5 Kashyap Chamarthy 2013-02-26 02:35:27 EST
Run a few basic keystone commands:

Source keystone_admin; list the users:
#===============================#
[tuser1@interceptor export(keystone_user1)]$ . ~/keystonerc_admin 
[tuser1@interceptor export(keystone_admin)]$ keystone user-list
+----------------------------------+-------+---------+-------+
|                id                |  name | enabled | email |
+----------------------------------+-------+---------+-------+
| 320ce46de7e24a75a7ff8906d7355ff7 | user1 |   True  |       |
| e34da0f70aaa4b86b97857299d66155f | admin |   True  |       |
+----------------------------------+-------+---------+-------+
[tuser1@interceptor export(keystone_admin)]$ 
#===============================#

list current tenants:
#===============================#
[tuser1@interceptor export(keystone_admin)]$ keystone tenant-list
+----------------------------------+-------+---------+
|                id                |  name | enabled |
+----------------------------------+-------+---------+
| 57ff99aae24b4035b52177a722c4091f |  rhos |   True  |
| 5aaa100a372248dd9c658f8b7775784c | admin |   True  |
+----------------------------------+-------+---------+
#===============================#

list all services from the Service Catalog:
#===============================#
[tuser1@interceptor export(keystone_admin)]$ keystone service-list
+----------------------------------+----------+----------+---------------------------+
|                id                |   name   |   type   |        description        |
+----------------------------------+----------+----------+---------------------------+
| 230a7026a7a34650aa91c0e70338eaa2 |   nova   | compute  |    Nova Compute Service   |
| 4e27c8d114294c3e8f003581e2fdf5df |  cinder  |  volume  |   Cinder Volume Service   |
| b019c85fd45a4e5c9c993aaaeebafbc0 | keystone | identity | Keystone Identity Service |
| d0d16080fbb748c7b18ae543b82e2d37 |  glance  |  image   |    Glance Image Service   |
+----------------------------------+----------+----------+---------------------------+
[tuser1@interceptor export(keystone_admin)]$ 
#===============================#

list configured service endpoints:
#===============================#
[tuser1@interceptor export(keystone_admin)]$ keystone endpoint-list
+----------------------------------+-----------+------------------------------------------+------------------------------------------+---------------+
|                id                |   region  |                publicurl                 |               internalurl                |               |
+----------------------------------+-----------+------------------------------------------+------------------------------------------+---------------+
| 06223f1ef4c7463485e130a5e575ac8f | regionOne | http://127.0.0.1:8774/v1.1/$(tenant_id)s | http://127.0.0.1:8774/v1.1/$(tenant_id)s | http://127.0.0|
| 128c662d8c354d7e819a908a7d401951 | regionOne |        http://127.0.0.1:5000/v2.0        |        http://127.0.0.1:5000/v2.0        |       http://1|
| 27ac8fde791a40019136d7b9899be3bd | regionOne |         http://127.0.0.1:9292/v1         |         http://127.0.0.1:9292/v1         |         http:/|
| df08bbe593de455c8b8eac2f85dc255d | regionOne |  http://127.0.0.1:8776/v1/$(tenant_id)s  |  http://127.0.0.1:8776/v1/$(tenant_id)s  |  http://127.0.|
+----------------------------------+-----------+------------------------------------------+------------------------------------------+---------------+
[tuser1@interceptor export(keystone_admin)]$ 
#===============================#


Additional Info:

Repository used for testing:
#===============================#
$ cat /etc/yum.repos.d/rhos.repo
[rhos-2.1]
name = Red Hat OpenStack 2.1
baseurl = http://download.devel.redhat.com/rel-eng/OpenStack/Folsom/latest/x86_64/os/
enabled = 1
gpgcheck = 0
#===============================#

Turning to VERIFIED per comment #4 & this comment
Comment 7 errata-xmlrpc 2013-03-21 15:04:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0672.html