Bug 896539

Summary: '/lib/modules/3.7.2-201.fc18.x86_64/build/include/linux/version.h' does not exist
Product: [Fedora] Fedora Reporter: Álvaro Castillo <midgoon>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-17 09:17:14 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Álvaro Castillo 2013-01-17 09:10:12 EST
Description of problem: I am trying compile AMD Catalyst official drivers, and I could not built it. Because I do not have version.h file. No such file. However, on the last kernel, I could built it because exists.


Version-Release number of selected component (if applicable):
3.7.2-201.fc18.x86_64
Fedora 18 - x86_64

Steps to Reproduce:
1. Download AMD Catalyst privative drivers over AMD Catalyst drivers webpage. http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.5&lang=English
2. Install kernel-devel kernel-headers gcc binutils make
3. Set permissions to amd....sh +x
4. ./amd....sh

Get fail build.

Expected results: Can build it.

Loading mirror speeds from cached hostfile
 * fedora: ftp.cica.es
 * rpmfusion-free: fedora.uib.no
 * rpmfusion-free-updates: fedora.uib.no
 * rpmfusion-nonfree: fedora.uib.no
 * rpmfusion-nonfree-updates: fedora.uib.no
 * updates: ftp.cica.es
Installed Packages
kernel.x86_64                                                             3.7.2-201.fc18                                                      installed
kernel-devel.x86_64                                                       3.7.2-201.fc18                                                      @updates 
kernel-headers.x86_64                                                     3.7.2-201.fc18                                                      @updates
Comment 1 Álvaro Castillo 2013-01-17 09:17:14 EST
https://bugzilla.redhat.com/show_bug.cgi?id=896539
Sorry, duplicated, thanks rnovacek #fedora-kde folk.

*** This bug has been marked as a duplicate of bug 892373 ***