Bug 901607

Summary: Add ability to promote/demote in pcs ordering constraints
Product: Red Hat Enterprise Linux 6 Reporter: Chris Feist <cfeist>
Component: pcsAssignee: Chris Feist <cfeist>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.5CC: cluster-maint, lnovich, rsteiger, slevine
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: pcs-0.9.64-1.el6.noarch Doc Type: Bug Fix
Doc Text:
Cause: Using the pcs tool it was not possible to promote/demote master slave resources Consequence: Master/slave resource could not be promoted/demoted using pcs Fix: Add ability for pcs to promote/demote master/slave resources using constriants Result: Constraints that promote/demote master/slave resources can now be created using pcs.
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-21 11:50:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Feist 2013-01-18 15:54:18 UTC
Description of problem:
The crm shell will allow you to promote/demote master/slave resources, pcs should be able to do the same.

Comment 1 Chris Feist 2013-01-18 15:58:21 UTC
The command line should be something like this:

pcs resource promote <resource>
pcs resource demote <resource>

Comment 8 Chris Feist 2013-08-13 21:38:47 UTC
This is done with the following syntax:

pcs constraint order promote Res1 then promote Res2

    order [action] <resource id> then [action] <resource id> [options]
        Add an ordering constraint specifying actions (start,stop,promote,
        demote) and if no action is specified the default action will be
        start.
        Available options are kind=Optional/Mandatory/Serialize and
        symmetrical=true/false

Comment 14 errata-xmlrpc 2013-11-21 11:50:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1633.html