Bug 901942

Summary: evolution can't read local mbox spool mail files
Product: [Fedora] Fedora Reporter: Carl Brune <brune>
Component: evolutionAssignee: Matthew Barnes <mbarnes>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 18CC: lucilanga, mbarnes, mcrha
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-21 14:12:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Carl Brune 2013-01-20 03:59:29 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build Identifier: 

I am attempting to read a local mbox spool mail file (/var/spool/mail/username) using evolution. I have created an account in evolution to receive email in this format. Upon opening this "Inbox" an error "Summary and folder mismatch, even after a sync". Evolution is able to extract the From/Subject/Date to make the tabular summary, but it is not possible to view the messages.

The mbox spool mail file in question only contains email generated by local cron jobs. I can read it fine with the command line "mail" command. I have tried putting the file other places such as /home/username and also using other mbox files which I know to be not corrupted. The problem persists. I used this approach a few years ago with fc10 with no problems.

If I run evolution from a terminal, I see the following warnings/errors:

(evolution:435): camel-local-provider-WARNING **: Didn't get the next message where I expected (5387) got 0 instead

(evolution:435): camel-WARNING **: CamelSpoolStore::get_folder_sync() set its GError but then reported success

(evolution:435): camel-WARNING **: Error message was: Summary and folder mismatch, even after a sync


Reproducible: Always

Steps to Reproduce:
1. create account to read mbox spool mail file
2. attempt to open corresponding inbox

Actual Results:  
Folder fails to open, messages cannot be viewed.

Expected Results:  
Folder should be opened w/o errors, and messages should be readable.

Comment 1 Milan Crha 2013-01-21 14:12:21 UTC
Thanks for a bug report. There is filled a similar upstream bug [1], thus I'm moving this there. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=675287

Comment 2 Fedora Update System 2013-02-04 12:47:16 UTC
evolution-mapi-3.6.3-2.fc18,evolution-data-server-3.6.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/evolution-mapi-3.6.3-2.fc18,evolution-data-server-3.6.3-2.fc18

Comment 3 Carl Brune 2013-02-09 19:20:17 UTC
I can confirm that updating to

evolution-data-server-3.6.3-2.fc18.x86_64 and
evolution-mapi-3.6.3-2.fc18.x86_64

from updates-testing solved my issue. Thanks, Carl B.

Comment 4 Fedora Update System 2013-02-20 03:57:50 UTC
evolution-mapi-3.6.3-2.fc18, evolution-data-server-3.6.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.