Bug 902373

Summary: Unowned directory in fontconfig
Product: [Fedora] Fedora Reporter: Michael Scherer <misc>
Component: fontconfigAssignee: Akira TAGOH <tagoh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: fonts-bugs, i18n-bugs, pnemade, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-24 03:27:18 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
patch to fix the issue
patch to partially fix the rawhide build ( due to bogus date ) none

Description Michael Scherer 2013-01-21 09:22:44 EST
fontconfig place a file /usr/share/xml/fontconfig/fonts.dtd , and /usr/share/xml/fontconfig/ end up unowned. And fontconfig should depend on xml-commons ( a empty package holding only directory ) since it place a directory in /usr/share/xml ( or the directory end being unowned )
Comment 1 Michael Scherer 2013-02-04 09:05:13 EST
Created attachment 692746 [details]
patch to fix the issue

here is a patch against rawhide to fix the issue
Comment 2 Michael Scherer 2013-02-04 09:07:32 EST
Created attachment 692747 [details]
patch to partially fix the rawhide build ( due to bogus date )
Comment 3 Fedora Update System 2013-02-12 06:24:01 EST
fontconfig-2.10.2-2.fc18 has been submitted as an update for Fedora 18.
Comment 4 Fedora Update System 2013-02-12 23:36:02 EST
Package fontconfig-2.10.2-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fontconfig-2.10.2-2.fc18'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-02-24 03:27:19 EST
fontconfig-2.10.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.