Bug 902612

Summary: [ALL LANG] Places->Desktop menu: Error: Could not open location 'file:///root/%E#.....' Error stating file '/root/xxx': No such file or directory occurred when login system with different locales.
Product: Red Hat Enterprise Linux 6 Reporter: Lijun Li <lijli>
Component: glib2Assignee: Colin Walters <walters>
Status: CLOSED WONTFIX QA Contact: Desktop QE <desktop-qa-list>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 6.4CC: eng-i18n-bugs, jkurik, luhaisheng0301, mboisver, mshao, qe-i18n-bugs, smaitra, tpelka
Target Milestone: rcKeywords: i18n, Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-01-08 06:13:53 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Could not open location error none

Description Lijun Li 2013-01-21 23:51:28 EST
Description of problem:
[ALL LANG] Places->Desktop menu: Error: Could not open location 'file:///root/%E#.....' Error stating file '/root/xxx': No such file or directory occurred when login system with different locales.

Version-Release number of selected component (if applicable):
[root@localhost ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 6.4 Beta (Santiago)
[root@localhost ~]# rpm -q redhat-menus
redhat-menus-14.0.0-3.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1. Install latest rhel6.4 client build.
2. Login with selecting a local language (ex. Japanese).
3. Click 'Update Names' on the 'Update standard folders to current language?' dialog.
4. Logout.
5. Login with selecting a different local language (ex. English) and Login again.
6. Click 'Update Names' on the 'Update standard folders to current language?' dialog.
7. Click Places->Desktop menu.


  
Actual results:
[ALL LANG] Places->Desktop menu: Error: Could not open location 'file:///root/%E#.....' Error stating file '/root/xxx': No such file or directory occurred when login system with different locales.

Expected results:
The Desktop location should be opened without error.

Additional info:
Comment 2 Lijun Li 2013-01-21 23:56:00 EST
Created attachment 684843 [details]
Could not open location error
Comment 3 A S Alam 2013-01-22 01:34:58 EST
can you please confirm with this bug with normal user also?
Comment 4 Lijun Li 2013-01-22 02:06:22 EST
(In reply to comment #3)
> can you please confirm with this bug with normal user also?

It's reproduced on both root and normal user.

Thanks,
Robert
Comment 5 RHEL Product and Program Management 2013-10-13 20:03:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2017-11-21 09:52:55 EST
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 7 Red Hat Bugzilla Rules Engine 2017-11-21 09:52:55 EST
Quality Engineering Management has reviewed and declined this request. You may appeal this decision by reopening this request.
Comment 10 Jan Kurik 2018-01-08 06:13:53 EST
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.