Bug 902861

Summary: pango-font pedantic warnings
Product: [Fedora] Fedora Reporter: Michael Cronenworth <mike>
Component: pangoAssignee: Akira TAGOH <tagoh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 18CC: fonts-bugs, i18n-bugs, mclasen, negativo17
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: pango-1.32.3-2.fc18 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-06-19 00:28:54 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
pango-font-pedantic.patch none

Description Michael Cronenworth 2013-01-22 09:38:57 EST
Created attachment 685210 [details]
pango-font-pedantic.patch

Starting in Pango 1.32, the pango-font.h header tries to store 64-bit values in a 32-bit enumerator. I have changed the enumerator to be #define's instead.

Patch attached.


Version-Release number of selected component (if applicable):
pango-1.32.3-1.fc18

  
Actual results:
/usr/include/pango-1.0/pango/pango-font.h:380:33: warning: ISO C restricts enumerator values to range of ‘int’ [-pedantic]


Expected results:
No compile warnings.
Comment 1 Michael Cronenworth 2013-01-22 09:41:38 EST
Well... not 64-bit values (duh) but unsigned int in a int.
Comment 2 Michael Cronenworth 2013-01-29 09:51:38 EST
I filed the bug and patch upstream.

https://bugzilla.gnome.org/show_bug.cgi?id=692808
Comment 3 Michael Cronenworth 2013-01-29 09:54:56 EST
It has been fixed in the latest pango release.

Could an update for Pango 1.32.6 for Fedora 18 be spun?
Comment 4 Fedora Admin XMLRPC Client 2013-05-14 08:13:00 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Simone Caronni 2013-06-13 16:28:37 EDT
Hello,

I'm trying to create a new package for Fedora 18 but I stepped into the same problem. I can update el6, f17 and f19+ but f18 will be lagging behind.

Bug is open since January, can someone push an update for Fedora 18?

koji build failing and log:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5500034
http://kojipkgs.fedoraproject.org//work/tasks/34/5500034/build.log

Thanks,
--Simone
Comment 6 Michael Cronenworth 2013-06-13 16:34:41 EDT
Simone, unfortunately Pango had some development releases in the 1.32 stable version branch. 1.32.6 is one of those releases.

My patch could be applied to the F18 package (1.32.3) without needing to worry about other packages in F18.

Worst case (as Red Hat maintainers sometimes ignore these bug reports): You will have to add a patch to your package to remove -Werror.
Comment 7 Akira TAGOH 2013-06-14 06:18:37 EDT
(In reply to Michael Cronenworth from comment #3)
> It has been fixed in the latest pango release.
> 
> Could an update for Pango 1.32.6 for Fedora 18 be spun?

maybe not because it requires newer fontconfig which may not be sufficient for updates since it has a lot of changes. or we could do that once it works fine on f19.
Comment 8 Akira TAGOH 2013-06-14 06:20:11 EDT
(In reply to Michael Cronenworth from comment #6)
> Simone, unfortunately Pango had some development releases in the 1.32 stable
> version branch. 1.32.6 is one of those releases.
> 
> My patch could be applied to the F18 package (1.32.3) without needing to
> worry about other packages in F18.
> 
> Worst case (as Red Hat maintainers sometimes ignore these bug reports): You
> will have to add a patch to your package to remove -Werror.

I'm planning to patch 1.32.3 out with it so far.
Comment 9 Simone Caronni 2013-06-14 06:30:07 EDT
(In reply to Akira TAGOH from comment #8)
> I'm planning to patch 1.32.3 out with it so far.

Yes please, that would be great!
Comment 10 Fedora Update System 2013-06-16 22:49:26 EDT
pango-1.32.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pango-1.32.3-2.fc18
Comment 11 Fedora Update System 2013-06-17 21:34:27 EDT
Package pango-1.32.3-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pango-1.32.3-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11104/pango-1.32.3-2.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-06-19 00:28:54 EDT
pango-1.32.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.