This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 903184

Summary: libvirtd from git segfaults on shutdown in _dbus_warn_check_failed
Product: [Fedora] Fedora Reporter: Richard W.M. Jones <rjones>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: berrange, clalancette, crobinso, eblake, itamar, jforbes, jyang, laine, libvirt-maint, veillard, virt-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 903282 (view as bug list) Environment:
Last Closed: 2013-03-04 12:16:43 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 903282    

Description Richard W.M. Jones 2013-01-23 07:16:16 EST
Description of problem:

libvirt compiled from git (55bfd020d8d9de40977832c4762728090df2bee3).

Run the daemon like this:

$ ./run gdb --args ./daemon/libvirtd --timeout 30

Run libguestfs-test-tool against this daemon so that a single
transient guest is created and destroyed.

Wait 30 seconds for libvirtd to timeout and exit.

(gdb) bt
#0  0x000000328c635ba5 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:63
#1  0x000000328c637358 in __GI_abort () at abort.c:90
#2  0x0000003291e30ab5 in _dbus_abort () at dbus-sysdeps.c:94
#3  0x0000003291e27545 in _dbus_warn_check_failed (
    format=0x3291e325b8 "Attempt to remove filter function %p user data %p, but no such filter has been added\n") at dbus-internals.c:290
#4  0x00007fffea28c710 in nwfilterDriverShutdown ()
    at nwfilter/nwfilter_driver.c:344
#5  0x00007ffff777e89f in virStateCleanup () at libvirt.c:846
#6  0x000000000040c823 in main (argc=<optimized out>, argv=<optimized out>)
    at libvirtd.c:1517


Version-Release number of selected component (if applicable):

libvirt from git (55bfd020d8d9de40977832c4762728090df2bee3)

How reproducible:

Happened 3 times for me.
Comment 1 Daniel Berrange 2013-01-23 07:20:34 EST
Yep, I've just seen that problem too & am investigating it
Comment 2 Daniel Berrange 2013-01-23 07:25:17 EST
Oh btw the problem likely exists in previous libvirt, but we were missing the virStateCleanup call for a few releases, which would have avoided triggering the problem
Comment 3 Daniel Berrange 2013-01-23 09:20:57 EST
Fixed in GIT with

commit abbec81bd0c9bf917f2c63045222734d7e4411fb
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Wed Jan 16 13:12:16 2013 +0000

    Fix nwfilter driver reload/shutdown handling when unprivileged
    
    Although the nwfilter driver skips startup when running in a
    session libvirtd, it did not skip reload or shutdown. This
    caused errors to be reported when sending SIGHUP to libvirtd,
    and caused an abort() in libdbus on shutdown due to trying
    to remove a dbus filter that was never added
Comment 4 Eric Blake 2013-01-23 10:32:11 EST
I'm backporting this to v0.10.2-maint, and leaving it in POST until F18 picks up the fix.
Comment 5 Fedora Update System 2013-01-28 17:14:34 EST
libvirt-0.10.2.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libvirt-0.10.2.3-1.fc18
Comment 6 Fedora Update System 2013-02-05 11:54:48 EST
libvirt-0.10.2.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.