This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 904014

Summary: doesn't ask for host name
Product: [Fedora] Fedora Reporter: Alexander van Loon <a.vanloon>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: anaconda-maint-list, g.kaviyarasu, jonathan, nick.alonge, sbueno, stephent98, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-29 09:40:25 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
screenshot showing hostname cannot be changed from System Settings:Details on Live none

Description Alexander van Loon 2013-01-25 04:31:46 EST
Description of problem:
Anaconda doesn't ask for the host name anymore if you're already connected to the Internet when Anaconda is started. Apparently it only is this way since F18, I remember Anaconda used to ask the question in F17. Anaconda chose a host name for my computer instead, which is linux.fritz.box based on the name of my router. Also see http://forums.fedoraforum.org/showthread.php?t=287539 for more information and a workaround.
Comment 1 Chris Lumens 2013-01-25 10:12:55 EST
While the initial network spoke does not pop up, there should still be the network spoke accessible from the main hub and there should be a hostname entry on that screen.  Are you seeing that?
Comment 2 Steve Tyler 2013-01-25 17:56:36 EST
There is no network spoke link on the Live image:
http://forums.fedoraforum.org/showpost.php?p=1626458&postcount=16

The host name can be configured post-install:

Click Activities, type "details" in the search box, click Details, and enter the "Device name".

Or follow the path:

Activities:Show Applications:System Tools:System Settings:Details:Overview:Device name
Comment 3 Alexander van Loon 2013-01-26 04:27:33 EST
After verifying myself I conclude there are two possibilities:

First, don't have an Internet/network connection active while you start up and proceed through Anaconda. In this case Anaconda asks network related questions right after you pick your language in the first step. Here you can also change the hostname and the option is obvious (some people in the forum topic mentioned this too IIRC).

Second, do have an Internet/network connection active while you start up and proceed through Anaconda. In this case you will go to the main hub after picking the language (no network configuration as a second step) and there is no network spoke there as Steve mentions.

Steve, I already tried changing the hostname that way through "Details", but I can't. I guess that deserves a different bug report. In the end I had to change the hostname with a command in the terminal.
Comment 4 Steve Tyler 2013-01-26 09:13:55 EST
Created attachment 688020 [details]
screenshot showing hostname cannot be changed from System Settings:Details on Live

Confirming that the hostname cannot be changed from the System Settings:Details dialog when running the Live image. Since the hostname can be changed with the hostnamectl command[1], this appears to be a Live bug, possibly with livecd-tools.

Alex: Can you set the hostname on the installed system from System Settings:Details?

[1] However, the installer fails to start after running the hostnamectl command:
Bug 893218, Comment 13.
Comment 5 Alexander van Loon 2013-01-26 09:36:22 EST
No, in my installed system I see the same as in your screenshot: the input field for the hostname is grayed out and I can't change it.
Comment 6 Steve Tyler 2013-01-26 15:10:41 EST
OK, thanks. I created a standard user account on an installed system and cannot change the hostname from System Settings:Details while logged in as a standard user. On Live, liveuser is a standard account. The bug here, IMO, is that there is no "Unlock" button in the Details dialog.

On your installed system, are you logged in as an administrative user or as a standard user?

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Final/Final/Fedora-18-x86_64-Live-Desktop.iso -vga qxl -boot menu=on -usbdevice mouse
Comment 7 Nicholas Alonge 2013-01-26 23:04:08 EST
I noticed the option to set up the network and choose a hostname was available in Anaconda only on the Install DVD and not the Live CD for me. 
I tried the Live CD in virtualbox, once with an internet connection and once without. Without a network connection Anaconda offered the network setup spoke, with it the option was not visible.

The install DVD presented the option in either scenario.

You can also change the hostname post-install using hostnamectl.

IMO, Anaconda should offer the network options on the Live CD regardless if it detects an internet connection or not.
Comment 8 Alexander van Loon 2013-01-27 05:00:37 EST
(In reply to comment #6)
> On your installed system, are you logged in as an administrative user or as
> a standard user?

Standard user.

(In reply to comment #7)
> IMO, Anaconda should offer the network options on the Live CD regardless if
> it detects an internet connection or not.

Agreed.
Comment 9 Steve Tyler 2013-01-27 05:41:15 EST
Here is a workaround for the installer crashing[1] after the hostname is changed on the Live CD:

Open a terminal.

$ liveinst # Quit from the Welcome dialog without installing.
$ hostnamectl set-hostname f18-test-2
$ liveinst

Complete the install.
Reboot into the installed system.

The hostname command returns "f18-test-2".

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Final/Final/Fedora-18-x86_64-Live-Desktop.iso -vga qxl -boot menu=on -usbdevice mouse

[1] Bug 893218, Comment 13
Comment 10 Steve Tyler 2013-01-27 06:01:44 EST
(In reply to comment #8)
> (In reply to comment #6)
> > On your installed system, are you logged in as an administrative user or as
> > a standard user?
> 
> Standard user.

If you login as an administrative user, can you change the hostname from System Settings:Details?

> (In reply to comment #7)
> > IMO, Anaconda should offer the network options on the Live CD regardless if
> > it detects an internet connection or not.
> 
> Agreed.

Likewise agreed. Even if the Live CD hostname could be set from System Settings:Details, a user who has never used Fedora before should not be forced to understand how to configure Fedora before installing.
Comment 11 Chris Lumens 2013-01-29 09:40:25 EST
On the live CD, we are trying to present as normal of an application as possible.  You are supposed to use the live environment's provided mechanism for setting up the hostname and other network information.  That's why anaconda does not provide this.  Our setup would just get in the way of, for instance, NM running during the live environment.
Comment 12 Alexander van Loon 2013-01-30 14:30:19 EST
(In reply to comment #11)
> On the live CD, we are trying to present as normal of an application as
> possible.  You are supposed to use the live environment's provided mechanism
> for setting up the hostname and other network information.  That's why
> anaconda does not provide this.  Our setup would just get in the way of, for
> instance, NM running during the live environment.

I don't get it and I'm really confused now. So in fact you're saying the Anaconda developers will remove the functionality to enter a hostname if the Live DVD is used, or if the Live CD is used without an Internet connection? So the user *being asked* to enter the hostname is the bug instead of the other way around?

If Anaconda gets in the way of NetworkManager and that's why Anaconda can't ask for the hostname, then why *was* it possible for Anaconda in older versions of Fedora?

(In reply to comment #10)
> If you login as an administrative user, can you change the hostname from
> System Settings:Details?

Yes. I'll file a bug at GNOME's Buzgilla for this. It should have an unluck button indeed.
Comment 13 Alexander van Loon 2013-01-31 04:38:38 EST
Filed bug at GNOME Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=692923
Comment 14 Steve Tyler 2013-01-31 11:17:39 EST
(In reply to comment #13)
> Filed bug at GNOME Bugzilla:
> https://bugzilla.gnome.org/show_bug.cgi?id=692923

Thanks, Alex. I commented there.
Comment 15 Steve Tyler 2013-01-31 11:23:39 EST
(In reply to comment #11)
> On the live CD, we are trying to present as normal of an application as
> possible.  You are supposed to use the live environment's provided mechanism
> for setting up the hostname and other network information.  That's why
> anaconda does not provide this.  Our setup would just get in the way of, for
> instance, NM running during the live environment.

"You are supposed to use the live environment's provided mechanism ..."

Where in the installer does it say this?