Bug 904150

Summary: [abrt] qemu-system-x86-1.2.2-1.fc18: die2: Process /usr/bin/qemu-kvm was killed by signal 6 (SIGABRT)
Product: [Fedora] Fedora Reporter: Richard W.M. Jones <rjones>
Component: qemuAssignee: Fedora Virtualization Maintainers <virt-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: amit.shah, berrange, cfergeau, crobinso, dwmw2, itamar, pbonzini, rjones, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:e8ec7ed0f0e96382a90544ec628cbeddcbe47669
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-01 18:03:47 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace
none
File: build_ids
none
File: cgroup
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
File: limits
none
File: maps
none
File: open_fds
none
File: proc_pid_status
none
File: var_log_messages none

Description Richard W.M. Jones 2013-01-25 10:14:17 EST
Description of problem:
Running the parallel mount test, part of the libguestfs test suite.

Version-Release number of selected component:
qemu-system-x86-1.2.2-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/qemu-kvm -name guestfs-az1s839kb2mw68gv -S -M pc-1.2 -enable-kvm -m 500 -smp 1,sockets=1,cores=1,threads=1 -uuid 805a9441-0872-3af2-4826-65a210ea9c30 -nographic -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/home/rjones/.config/libvirt/qemu/lib/guestfs-az1s839kb2mw68gv.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-reboot -no-shutdown -no-acpi -kernel /home/rjones/d/libguestfs/tmp/.guestfs-1000/kernel.6839 -initrd /home/rjones/d/libguestfs/tmp/.guestfs-1000/initrd.6839 -append 'panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 TERM=xterm-256color' -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x3 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x4 -drive file=/home/rjones/d/libguestfs/tests/mount-local/test11.img,if=none,id=drive-scsi0-0-0-0,format=raw,cache=none -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 -drive file=/home/rjones/d/libguestfs/tmp/libguestfsOLm2Zw/snapshot1,if=none,id=drive-scsi0-0-1-0,format=qcow2,cache=unsafe -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=1,lun=0,drive=drive-scsi0-0-1-0,id=scsi0-0-1-0 -chardev socket,id=charserial0,path=/home/rjones/d/libguestfs/tmp/libguestfsOLm2Zw/console.sock -device isa-serial,chardev=charserial0,id=serial0 -chardev socket,id=charchannel0,path=/home/rjones/d/libguestfs/tmp/libguestfsOLm2Zw/guestfsd.sock -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.libguestfs.channel.0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5
crash_function: die2
executable:     /usr/bin/qemu-kvm
kernel:         3.7.2-204.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (4 frames)
 #2 die2 at posix-aio-compat.c:84
 #3 thread_create at posix-aio-compat.c:122
 #4 do_spawn_thread at posix-aio-compat.c:408
 #5 aio_thread at posix-aio-compat.c:320
Comment 1 Richard W.M. Jones 2013-01-25 10:15:02 EST
Created attachment 687508 [details]
File: backtrace
Comment 2 Richard W.M. Jones 2013-01-25 10:15:05 EST
Created attachment 687509 [details]
File: build_ids
Comment 3 Richard W.M. Jones 2013-01-25 10:15:07 EST
Created attachment 687510 [details]
File: cgroup
Comment 4 Richard W.M. Jones 2013-01-25 10:15:11 EST
Created attachment 687511 [details]
File: core_backtrace
Comment 5 Richard W.M. Jones 2013-01-25 10:15:15 EST
Created attachment 687512 [details]
File: dso_list
Comment 6 Richard W.M. Jones 2013-01-25 10:15:19 EST
Created attachment 687513 [details]
File: environ
Comment 7 Richard W.M. Jones 2013-01-25 10:15:24 EST
Created attachment 687514 [details]
File: limits
Comment 8 Richard W.M. Jones 2013-01-25 10:15:28 EST
Created attachment 687515 [details]
File: maps
Comment 9 Richard W.M. Jones 2013-01-25 10:15:34 EST
Created attachment 687516 [details]
File: open_fds
Comment 10 Richard W.M. Jones 2013-01-25 10:15:38 EST
Created attachment 687517 [details]
File: proc_pid_status
Comment 11 Richard W.M. Jones 2013-01-25 10:15:42 EST
Created attachment 687518 [details]
File: var_log_messages
Comment 12 Richard W.M. Jones 2013-01-25 10:16:27 EST
Actually this crash happened twice.
Comment 13 Richard W.M. Jones 2013-01-29 06:23:10 EST
Actually multiple times now.
Comment 14 Cole Robinson 2013-04-01 15:51:34 EDT
Rich are you still seeing this on latest F18 packages?

pthread_create is failing. It should be showing strerror on stderr, but abrt didn't report it...
Comment 15 Richard W.M. Jones 2013-04-01 17:14:19 EDT
The answer is I've been using qemu 1.4.0 from Rawhide for
a while now, and it's been rock solid.  I don't really
care about the F18 package.

This raises the side question of why we don't just upgrade
qemu to 1.4.0 in F18 too.

But in any case, I don't care about this bug and I've not
personally experienced it since January, so feel free to
close it unless anyone else has seen it.
Comment 16 Cole Robinson 2013-04-01 18:03:47 EDT
(In reply to comment #15)
> The answer is I've been using qemu 1.4.0 from Rawhide for
> a while now, and it's been rock solid.  I don't really
> care about the F18 package.
> 
> This raises the side question of why we don't just upgrade
> qemu to 1.4.0 in F18 too.
> 

Same reason to avoid any rebase of a critical component: risk of regressions and increased effort.

> But in any case, I don't care about this bug and I've not
> personally experienced it since January, so feel free to
> close it unless anyone else has seen it.

Thanks, closing then.