Bug 905083

Summary: Endless loop if scp is missing on nodes
Product: [Fedora] Fedora EPEL Reporter: Sandro Mathys <sandro>
Component: openstack-packstackAssignee: Martin Magr <mmagr>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: el6CC: derekh, mmagr, p
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-17 12:19:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sandro Mathys 2013-01-28 14:33:47 UTC
Description of problem:
Running packstack on a few minimal installations, I noticed it will run into an endless loop if scp is missing on the nodes.

Version-Release number of selected component (if applicable):
openstack-packstack-2012.2.2-0.5.dev318.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Setup a host and a node, the latter without installing the scp binary (i.e. openssh-clients package)
2. Run packstage
3. Watch it loop at "Testing if puppet apply is finished : <node IP>_prescript.pp"
  
Actual results:
Endless loop.

Expected results:
Either exit with an error or install what's missing (beforehand, since you know you're going to need it for sure) and continue.

Additional info:
Testing if puppet apply is finished : 10.112.1.30_prescript.pp
DEBUG:root:# ============ ssh : None ==========
DEBUG:root:scp -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@10.112.1.28:/var/tmp/3ff889d0-da2b-4651-9f52-242afaade21f/manifests/10.112.1.28_prescript.pp.finished /var/tmp/3ff889d0-da2b-4651-9f52-242afaade21f/manifests/10.112.1.28_prescript.pp.log
DEBUG:root:============ STDOUT ==========
DEBUG:root:
DEBUG:root:============= STDERR ==========
DEBUG:root:+ trap t ERR
+ scp -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@10.112.1.28:/var/tmp/3ff889d0-da2b-4651-9f52-242afaade21f/manifests/10.112.1.28_prescript.pp.finished /var/tmp/3ff889d0-da2b-4651-9f52-242afaade21f/manifests/10.112.1.28_prescript.pp.log
Warning: Permanently added '10.112.1.28' (RSA) to the list of known hosts.
bash: scp: command not found
++ t
++ exit 1

Comment 1 Derek Higgins 2013-01-30 12:07:24 UTC
thanks for finding this

Fix submitted upstream
https://review.openstack.org/20802

Comment 2 Fedora Update System 2013-02-13 18:57:23 UTC
openstack-packstack-2012.2.2-0.8.dev406.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/openstack-packstack-2012.2.2-0.8.dev406.el6

Comment 3 Fedora Update System 2013-02-13 18:59:15 UTC
openstack-packstack-2012.2.2-0.8.dev406.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-packstack-2012.2.2-0.8.dev406.fc18

Comment 4 Fedora Update System 2013-02-15 04:59:14 UTC
Package openstack-packstack-2012.2.2-0.8.dev406.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-packstack-2012.2.2-0.8.dev406.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2483/openstack-packstack-2012.2.2-0.8.dev406.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-02-21 13:37:19 UTC
openstack-packstack-2012.2.2-1.0.dev408.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-packstack-2012.2.2-1.0.dev408.fc18

Comment 6 Fedora Update System 2013-02-21 13:39:12 UTC
openstack-packstack-2012.2.2-1.0.dev408.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/openstack-packstack-2012.2.2-1.0.dev408.el6

Comment 7 Fedora Update System 2013-02-27 12:39:25 UTC
openstack-packstack-2012.2.3-0.1.dev454.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openstack-packstack-2012.2.3-0.1.dev454.fc18