Bug 908521

Summary: [mr][ta_IN][ml] pofilter filepaths test failed for subscription-manager 1.8.X
Product: Red Hat Enterprise Linux 7 Reporter: John Sefler <jsefler>
Component: subscription-managerAssignee: Ani Peter <apeter>
Status: CLOSED CURRENTRELEASE QA Contact: IDM QE LIST <seceng-idm-qe-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.0CC: alikins, apeter, bkearney, fsharath, jgalipea, shkumar, sshedmak, swgoswam
Target Milestone: rcKeywords: i18n, Translation
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-01 09:48:44 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 840995, 863175    
Attachments:
Description Flags
not yet fixed in Zanata, therefore not yet fixed in subscription-manager rpm none

Description John Sefler 2013-02-06 17:20:17 EST
Description of problem:

# (pofilter) filepaths: Different file paths
msgid "Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information."
msgstr "नेटवर्क त्रुटी, सर्व्हरशी जोडणी करणे अशक्य. कृपया /var/log/rhsm/rhsm पहा. अधिक माहितीकरीता लॉग पहा."

THE SUFFIX ".log" SHOULD NOT BE DROPPED FROM THE FULL PATH TO THE FILE IN THE msgstr.


Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.8.1-1.git.9.f23e0b0.el7.x86_64
https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.8.X

How reproducible:


Steps to Reproduce:
[root@jsefler-7 ~]# msgunfmt --no-wrap /usr/share/locale/mr/LC_MESSAGES/rhsm.mo | grep -A2 "Please see"
msgid "Error in preferences dialog. Please see /var/log/rhsm/rhsm.log for more information."
msgstr "पसंती संवादात त्रुटी. अधिक माहितीकरीता कृपया /var/log/rhsm/rhsm.log पहा."

--
msgid "Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information."
msgstr "नेटवर्क त्रुटी, सर्व्हरशी जोडणी करणे अशक्य. कृपया /var/log/rhsm/rhsm पहा. अधिक माहितीकरीता लॉग पहा."

--
msgid "Please see /var/log/rhsm/rhsm.log for more information."
msgstr "अधिक माहितीकरीता कृपया /var/log/rhsm/rhsm.log पहा."

  
Actual results:
above
Comment 1 John Sefler 2013-02-06 17:40:32 EST
Also failing against language ta_IN...

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num-இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."
                                      ^
                                      ^
            PLEASE REMOVE THIS HYPHEN ^
Comment 2 John Sefler 2013-02-06 17:55:15 EST
Also failing against language ml...

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num-ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."
                                      ^
                                      ^
            PLEASE REMOVE THIS HYPHEN ^
Comment 3 sandeep shedmake 2013-02-07 00:12:38 EST
'mr' fix available upstream.

[sshedmak@dhcp193-69 mr]$ msgunfmt --no-wrap rhsm.mo | grep -A2 "Please see"
msgid "Error in preferences dialog. Please see /var/log/rhsm/rhsm.log for more information."
msgstr "पसंती संवादात त्रुटी. अधिक माहितीकरिता कृपया /var/log/rhsm/rhsm.log पहा."

--
msgid "Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information."
msgstr "नेटवर्क त्रुटी, सर्व्हरशी जोडणी करणे अशक्य. कृपया अधिक माहितीकरिता /var/log/rhsm/rhsm.log लॉग पहा."

--
msgid "Please see /var/log/rhsm/rhsm.log for more information."
msgstr "अधिक माहितीकरिता कृपया /var/log/rhsm/rhsm.log पहा."

[sshedmak@dhcp193-69 mr]$ echo $?
0


Thanks!
Comment 4 Shantha kumar 2013-02-07 02:04:11 EST
ta-IN Fixed:

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."
Comment 5 Adrian Likins 2013-03-25 17:34:46 EDT
commit 008c5cb336b141f300d647d6c71750b2cd15e066
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Mar 25 15:03:16 2013 -0400

    921126: latest string updates from zanata
    
    921126,911779,911776,911772,911764,911762,911759,
    911757,908886,908879,908869,908866,908521,908511,
    908488,908434,908108,908059,908037,906967,906552,
    842784
Comment 6 John Sefler 2013-03-27 15:07:32 EDT
not yet fixed in LANG ml
Moving back to ASSIGNED/FailedQA
Comment 7 Bryan Kearney 2013-04-19 13:33:48 EDT
[bkearney@bkearney subscription-manager]$ pofilter --gnome  filepaths -i po/ta_IN.po
processing 1 files...
[###########################################] 100%
[bkearney@bkearney subscription-manager]$ pofilter --gnome  filepaths -i po/mr.po 
processing 1 files...
[###########################################] 100%
[bkearney@bkearney subscription-manager]$ pofilter --gnome  filepaths -i po/ml.po 
processing 1 files...
[###########################################] 100%


Fixed in 1.8.6
Comment 8 Bryan Kearney 2013-04-19 14:02:58 EDT
the comment in 7 is incorrect, but the failures are due to being at the end of the sentance.
Comment 9 John Sefler 2013-04-23 13:34:12 EDT
Created attachment 739091 [details]
not yet fixed in Zanata, therefore not yet fixed in subscription-manager rpm

[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.8.6-1.el7.x86_64

[root@jsefler-7 ~]#  msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo | grep install-num
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num-ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."
                                      ^
                                      ^
                                      ^
                   REMOVE THIS HYPHEN ^
Comment 10 Ani Peter 2013-07-23 01:25:33 EDT
Have fixed the translations in Zanata for 1.8.X:

https://translate.zanata.org/zanata/webtrans/translate?project=subscription-manager&iteration=1.8.X&localeId=ml&locale=en

Thanks
Ani
Comment 11 Bryan Kearney 2013-07-29 12:22:06 EDT
The translations for ml and ta_IN will pulled in via 

f5f72130cbe5e5f1458c19a88a6828454a97844e         (927990 string fixes)
e49e201faf25336bca4991a5d981c8602cedaa99        (928469 string fixes)


The mr strings were pulled in at 

commit 91dd957e9716db13233ec1be7ba432eaa8de18ad
Author: Bryan Kearney <bkearney@redhat.com>
Date:   Mon Jul 29 12:21:11 2013 -0400

    908521: Pull in the latest mr strings
Comment 13 Bryan Kearney 2013-08-01 11:55:07 EDT
Moving these to ON_QA. The tooling must have missed moving these.
Comment 14 Sharath Dwaral 2013-08-05 13:50:23 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.8.16-1.el5
subscription-manager-debuginfo-1.8.16-1.el5
subscription-manager-migration-data-1.11.3.2-1.git.0.14f9d59.el5
subscription-manager-firstboot-1.8.16-1.el5
python-rhsm-1.8.16-1.el5
subscription-manager-migration-1.8.16-1.el5
python-rhsm-debuginfo-1.8.16-1.el5
subscription-manager-gui-1.8.16-1.el5



Verification:

Language: mr

# msgunfmt --no-wrap /usr/share/locale/mr/LC_MESSAGES/rhsm.mo | grep -A2 "Please see"
msgid "Error in preferences dialog.Please see /var/log/rhsm/rhsm.log for more information."
msgstr "पसंती संवादमध्ये त्रुटी.अधिक माहितीकरिता कृपया /var/log/rhsm/rhsm.log पहा."

--
msgid "Network error, unable to connect to server. Please see /var/log/rhsm/rhsm.log for more information."
msgstr "नेटवर्क त्रुटी, सर्व्हरशी जोडणी करणे अशक्य. कृपया अधिक माहितीकरिता /var/log/rhsm/rhsm.log लॉग पहा."

--
msgid "Please see /var/log/rhsm/rhsm.log for more information."
msgstr "अधिक माहितीकरिता कृपया /var/log/rhsm/rhsm.log पहा."


Language: ml

# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo | grep -A2 "/etc/sysconfig/rhn/install-"
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."

Language: tn_IN


# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo | grep -A2 "/etc/sysconfig/rhn/install-"
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."


VERIFIED