Bug 910737

Summary: df: cannot read table of mounted file systems
Product: [Fedora] Fedora Reporter: Pierre-YvesChibon <pingou>
Component: coreutilsAssignee: Ondrej Vasik <ovasik>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: admiller, kdudka, kzak, ooprala, ovasik, p, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-14 21:00:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pierre-YvesChibon 2013-02-13 12:45:02 UTC
Description of problem:
$ df -h
df: cannot read table of mounted file systems

Version-Release number of selected component (if applicable):
 kernel-3.7.5-201.fc18.x86_64
 coreutils-8.17-8.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot
2. df -h
3.
  
Actual results:
shown above

Expected results:
working df :)

Additional info:

Comment 1 Pierre-YvesChibon 2013-02-13 12:47:57 UTC
After discussing on IRC, this might be related to the kernel.

Comment 2 Pádraig Brady 2013-02-13 21:38:34 UTC
There was a problem with rpm-4.10.2-2 that caused it to remove the /etc/mtab symlink, which in turn might give the error above. Could you ensure /etc/mtab -> /proc/mounts is in place if not.

Comment 3 Ondrej Vasik 2013-02-14 21:00:24 UTC
As Pádraig said, it has nothing to do with coreutils and deleted symlink was reported (problem with rpm, in combination with handling of the symlink in util-linux %post). Anyway, as this issue is already tracked in other bugzilla, closing duplicate...

*** This bug has been marked as a duplicate of bug 887763 ***