Bug 913373

Summary: Ctrl-Enter not moving to next trans unit if there are no changes.
Product: [Retired] Zanata Reporter: Carlos Munoz <camunoz>
Component: Component-UI, UsabilityAssignee: Patrick Huang <pahuang>
Status: CLOSED CURRENTRELEASE QA Contact: Ding-Yi Chen <dchen>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 2.1CC: zanata-bugs
Target Milestone: ---   
Target Release: 2.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 2.2-SNAPSHOT (20130225-1231) Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-27 03:23:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Carlos Munoz 2013-02-21 05:40:53 UTC
Description of problem:
When hitting Ctrl-Enter on a translation unit with no changes, the cursor should go to the next entry.

Version-Release number of selected component (if applicable):
2.1.x

How reproducible:
Always

Steps to Reproduce:
1. Open the web editor on any document.
2. Go to any translation unit. Hit Ctrl-Enter. Since there are no changes the cursor stays on the same translation unit.
3. Change the current translation. Hit Ctrl-Enter. The translation is saved and the cursor moves to the next trans unit as expected.
  
Actual results:
Per steps above.

Expected results:
Per steps above.

Comment 1 Patrick Huang 2013-02-22 03:21:56 UTC
committed into master:
https://github.com/zanata/zanata/commit/6f2482f40c13a3d47d82abaff4f210834e53c4b8

Comment 2 Ding-Yi Chen 2013-02-25 03:12:38 UTC
VERIFIED with Zanata version 2.2-SNAPSHOT (20130225-1231)

Comment 3 Sean Flanigan 2013-11-27 03:13:17 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 4 Sean Flanigan 2013-11-27 03:15:22 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 5 Sean Flanigan 2013-11-27 03:18:27 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 6 Sean Flanigan 2013-11-27 03:23:14 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 7 Sean Flanigan 2013-11-27 03:33:08 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.

Comment 8 Sean Flanigan 2013-11-27 03:35:23 UTC
Closing VERIFIED bugs for Zanata versions <= 3.1.