Bug 915433

Summary: [abrt] rapid-photo-downloader-0.4.6-1.fc18: rapid.py:2810:notify_downloaded_from_device:GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
Product: [Fedora] Fedora Reporter: phil <fedora2009>
Component: rapid-photo-downloaderAssignee: Fabian Affolter <mail>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: mail, tech
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:d115459420636a9ed99ad26da1e9838fcac9254b
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-06-27 19:58:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace
none
File: core_backtrace
none
File: environ
none
File: smolt_data none

Description phil 2013-02-25 18:01:23 UTC
Description of problem:
download photos from sd card

Version-Release number of selected component:
rapid-photo-downloader-0.4.6-1.fc18

Additional info:
cmdline:        /usr/bin/python /bin/rapid-photo-downloader /run/media/phil/CANON_DC
executable:     /bin/rapid-photo-downloader
kernel:         3.7.9-201.fc18.x86_64
uid:            500

Truncated backtrace:
rapid.py:2810:notify_downloaded_from_device:GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/rapid/rapid.py", line 1418, in task_results
    self.results_callback(move_succeeded, rpd_file, download_count)
  File "/usr/lib/python2.7/site-packages/rapid/rapid.py", line 2593, in subfolder_file_results
    self.file_download_finished(move_succeeded, rpd_file)
  File "/usr/lib/python2.7/site-packages/rapid/rapid.py", line 2681, in file_download_finished
    self.notify_downloaded_from_device(scan_pid)
  File "/usr/lib/python2.7/site-packages/rapid/rapid.py", line 2810, in notify_downloaded_from_device
    n.show()
GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files

Local variables in innermost frame:
notification_name: 'CANON_DC'
scan_pid: 2756
no_files_downloaded: 1
self: <rapid.rapid.RapidApp at / at 0x7f9fb9ac5a10>
n: <pynotify.Notification object at 0x2a6e8c0 (NotifyNotification at 0x2b63a20)>
device: <rapid.device.Device instance at 0x240f1b8>
no_warnings: 0
file_types_failed: 'photos'
no_photos_downloaded: 1
no_files_failed: 7
no_videos_failed: 0
message: '1 photo downloaded\n7 photos failed to download'
icon: <gtk.gdk.Pixbuf object at 0x2a6e960 (GdkPixbuf at 0x2b79d40)>
no_videos_downloaded: 0
file_types: 'photo'
no_photos_failed: 7

Comment 1 phil 2013-02-25 18:01:27 UTC
Created attachment 702462 [details]
File: backtrace

Comment 2 phil 2013-02-25 18:01:30 UTC
Created attachment 702463 [details]
File: core_backtrace

Comment 3 phil 2013-02-25 18:01:36 UTC
Created attachment 702464 [details]
File: environ

Comment 4 phil 2013-02-25 18:01:40 UTC
Created attachment 702465 [details]
File: smolt_data

Comment 5 KitchM 2013-05-08 17:42:35 UTC
What is the status of this bug report?  Is anyone working on it?

Comment 6 KitchM 2013-06-13 14:26:47 UTC
Still happening every time I open Rapid Photo Downloader.

Comment 7 Fabian Affolter 2013-06-27 19:58:41 UTC

*** This bug has been marked as a duplicate of bug 816287 ***