Bug 916472

Summary: "Communications with UPS lost" during package upgrade
Product: [Fedora] Fedora Reporter: Jordan Russell <jr-redhatbugs2>
Component: nutAssignee: Michal Hlavinka <mhlavink>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: mhlavink
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: nut-2.6.5-12.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-17 03:24:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jordan Russell 2013-02-28 06:57:56 UTC
Description of problem:
While the nut packages are being upgraded with yum, an alarming "Communications with UPS lost" message sometimes gets wall'ed to the console.

It appears this happens because nut-server.service is stopped while nut-monitor.service is still running.

To avoid these spurious errors during upgrades, I believe it should stop/start the services in a specific order:
1. Stop nut-monitor
2. Stop nut-server
3. Stop nut-driver
4. Start nut-server (pulls in nut-driver automatically)
5. Start nut-monitor

Version-Release number of selected component (if applicable):
2.6.5-6.fc17

Comment 1 Michal Hlavinka 2013-02-28 13:28:20 UTC
Unfortunately, this is not that easy. nut-monitor and nut-server does not have to be running on the same system. They are split to two packages and we can't affect in what order packages are updated by yum.

I'll try to come up with some solution.

Comment 2 Fedora Update System 2013-04-23 08:19:16 UTC
nut-2.6.5-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nut-2.6.5-9.fc18

Comment 3 Fedora Update System 2013-04-23 08:19:26 UTC
nut-2.6.5-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nut-2.6.5-12.fc19

Comment 4 Fedora Update System 2013-04-23 16:43:22 UTC
Package nut-2.6.5-12.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nut-2.6.5-12.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6351/nut-2.6.5-12.fc19
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-05-17 03:24:17 UTC
nut-2.6.5-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2013-05-24 20:37:01 UTC
nut-2.6.5-12.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.