Bug 923348

Summary: i915: wrong video mode set during boot
Product: [Fedora] Fedora Reporter: Jaroslav ┼ákarvada <jskarvad>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-20 09:10:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jaroslav Škarvada 2013-03-19 16:03:11 UTC
Description of problem:
On my Lenovo t500 and kernel-3.8.3-201 wrong video mode is set during boot. There is cca 20% unused free space on the bottom of the LCD and when the gdm later starts it uses much lower resolution (1024x768) than is my native resolution (1680x1050).

Version-Release number of selected component (if applicable):
kernel-3.8.3-201

How reproducible:
Always

Steps to Reproduce:
1. Boot
  
Actual results:
Wrong video mode is set

Expected results:
Video mode with native resolution that fits whole screen is set

Additional info:
This seems to be an regression. It works correctly with kernel-3.8.2-206.
Also I have the following in my /etc/default/grub:
GRUB_TERMINAL="console"

Comment 1 Josh Boyer 2013-03-19 17:32:09 UTC
Please test https://admin.fedoraproject.org/updates/kernel-3.8.3-203.fc18

Comment 2 Jaroslav Škarvada 2013-03-20 09:10:35 UTC
It fixes the problem for me, sorry for the dupe.

*** This bug has been marked as a duplicate of bug 922304 ***