Bug 924340 (CVE-2013-1883)

Summary: CVE-2013-1883 mantis: Site / db server DoS via certain View Issues page search query
Product: [Other] Security Response Reporter: Jan Lieskovsky <jlieskov>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: NEW --- QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: extras-orphan, giallu, sven
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=moderate,public=20130306,reported=20130321,source=oss-security,cvss2=5.0/AV:N/AC:L/Au:N/C:N/I:N/A:P,fedora-all/mantis=affected,epel-5/mantis=affected
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 924341, 924342    
Bug Blocks:    

Description Jan Lieskovsky 2013-03-21 11:11:14 EDT
A denial of service flaw was found in the way MantisBT, a free popular web-based issue tracking system, performed processing of certain type of View Issues page search queries. A remote attacker could provide a specially-crafted query (filter combining some criteria and a text search with 'any condition') that, when processed by the MantisBT system, would lead to excessive system resources consumption (denial of service), possibly leading to complete MantisBT server instance unavailability.

[1] http://www.openwall.com/lists/oss-security/2013/03/21/3

Upstream bug report:
[2] http://www.mantisbt.org/bugs/view.php?id=15573

Relevant upstream patch:
[3] https://github.com/mantisbt/mantisbt/commit/d16988c3ca232a7
Comment 1 Jan Lieskovsky 2013-03-21 11:13:05 EDT
This issue affects the versions of the mantis package, as shipped with Fedora release of 17, 18, and Fedora EPEL-5. Please schedule an update.
Comment 2 Jan Lieskovsky 2013-03-21 11:14:09 EDT
Created mantis tracking bugs for this issue

Affects: fedora-all [bug 924341]
Affects: epel-5 [bug 924342]
Comment 3 Jan Lieskovsky 2013-03-22 05:49:00 EDT
The CVE identifier of CVE-2013-1883 has been assigned:


to this issue.
Comment 4 Fedora Update System 2013-03-31 23:26:03 EDT
mantis-1.2.14-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-03-31 23:32:18 EDT
mantis-1.2.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.