Bug 926953

Summary: multicast snooping blocks multicast traffic on kvm virtual hosts
Product: [Fedora] Fedora Reporter: W. de Heiden <wdh>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 18CC: amit.shah, berrange, cfergeau, clalancette, dallan, dwmw2, ehabkost, extras-orphan, gansalmon, itamar, jforbes, jonathan, jyang, kernel-maint, laine, libvirt-maint, madhu.chinakonda, markmc, notting, pbonzini, quintela, rjones, scottt.tw, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-26 17:44:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description W. de Heiden 2013-03-24 12:33:09 UTC
Description of problem:
Mutlicast between virtual KVM hosts gets dropped after a short period

Version-Release number of selected component (if applicable):
Fedora 18

Name        : qemu-kvm
Epoch       : 2
Version     : 1.2.2
Release     : 6.fc18

Name        : libvirt
Version     : 0.10.2.3
Release     : 1.fc18

How reproducible:
Instal omping on both virtual hosts. A low number of ping wil turn out OK, but giving a higher number, the multicast packet loss gets huge:

omping <remote ip> local ip> -c500  (on both hosts)

192.168.1.211 :   unicast, xmt/rcv/%loss = 500/500/0%, min/avg/max/std-dev = 0.330/0.610/0.789/0.064
192.168.1.211 : multicast, xmt/rcv/%loss = 500/268/46%, min/avg/max/std-dev = 0.416/0.635/0.921/0.066

After turning off "multicast snooping", the packet loss will disappear:

echo 0 > /sys/class/net/virbr0/bridge/multicast_snooping

omping <remote ip> local ip> -c500
192.168.1.212 :   unicast, xmt/rcv/%loss = 500/500/0%, min/avg/max/std-dev = 0.353/0.623/0.944/0.075
192.168.1.212 : multicast, xmt/rcv/%loss = 500/500/0%, min/avg/max/std-dev = 0.356/0.642/0.964/0.078 

Steps to Reproduce:
1. install Fedora 18 + KVM 
2. install 2 virtual (fedora) host and omping
3. start multicast test between virtual host using omping
  
Actual results:
Huge packet loss after apr. 200 ping.

Expected results:
0% packet loss

Additional info:

Comment 1 Paolo Bonzini 2013-03-26 17:35:11 UTC
The bridge is set up by libvirt, changing component.

Comment 2 Dave Allan 2013-03-26 17:44:01 UTC
I believe this is a duplicate of 880035, please reopen if you disagree.

*** This bug has been marked as a duplicate of bug 880035 ***