Bug 927170

Summary: perl provides perl(Carp) but doesn't include the module itself
Product: [Fedora] Fedora Reporter: Dominik 'Rathann' Mierzejewski <dominik>
Component: perlAssignee: Marcela Mašláňová <mmaslano>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cweyl, fedora, iarnell, jplesnik, kasal, lkundrak, mmaslano, perl-devel, ppisar, psabata, rc040203, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-25 09:35:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dominik 'Rathann' Mierzejewski 2013-03-25 09:24:54 UTC
Description of problem:
perl provides perl(Carp)

$ rpm -q --provides perl |grep Carp
perl(Carp)
$ rpm -ql perl |grep Carp

Version-Release number of selected component (if applicable):
$ rpm -q perl
perl-5.16.3-265.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. install perl package
2. try to run anything which requires the Carp module (for example autoreconf)
  
Actual results:
Can't locate Carp.pm in @INC (@INC contains: /usr/share/autoconf /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/autoconf/Autom4te/Channels.pm line 72.
BEGIN failed--compilation aborted at /usr/share/autoconf/Autom4te/Channels.pm line 72.
Compilation failed in require at /usr/share/autoconf/Autom4te/ChannelDefs.pm line 19.
BEGIN failed--compilation aborted at /usr/share/autoconf/Autom4te/ChannelDefs.pm line 19.
Compilation failed in require at /usr/bin/autoreconf line 39.
BEGIN failed--compilation aborted at /usr/bin/autoreconf line 39.

Expected results:
autoreconf should work normally

Additional info:
autoreconf works if I install perl-Carp manually.
$ rpm -q perl-Carp
perl-Carp-1.26-241.fc19.noarch

Comment 1 Remi Collet 2013-03-25 09:35:15 UTC

*** This bug has been marked as a duplicate of bug 924938 ***