Bug 928915

Summary: Review Request: php-phpunit-PHPUnit-Story - Story extension for PHPUnit to facilitate Behaviour-Driven Development
Product: [Fedora] Fedora Reporter: Remi Collet <fedora>
Component: Package ReviewAssignee: Shawn Iwinski <shawn>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: notting, package-review, shawn
Target Milestone: ---Flags: shawn: fedora-review+
gwync: fedora-cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-11 23:21:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 929039    
Attachments:
Description Flags
fedora-review
none
phpci none

Description Remi Collet 2013-03-28 17:51:23 UTC
Spec URL: https://raw.github.com/remicollet/remirepo/f0e70fd6e225109c466fc9047318b2350592a6dc/php/phpunit/php-phpunit-PHPUnit-Story/php-phpunit-PHPUnit-Story.spec
SRPM URL: http://rpms.famillecollet.com/SRPMS/php-phpunit-PHPUnit-Story-1.0.1-1.remi.src.rpm
Description: 
Story extension for PHPUnit to facilitate Behaviour-Driven Development

Fedora Account System Username: remi

Comment 1 Shawn Iwinski 2013-04-01 19:14:00 UTC
Created attachment 730394 [details]
fedora-review

Generated by fedora-review 0.4.0 (660ce56) last change: 2013-01-29
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review --mock-config fedora-rawhide-x86_64 -b 928915

Comment 2 Shawn Iwinski 2013-04-01 19:14:54 UTC
Created attachment 730395 [details]
phpci

phpci version 2.13.2

Comment 3 Shawn Iwinski 2013-04-01 19:16:27 UTC
===== SHOULD items =====
[!]: Final provides and requires are sane (see attachments).
     
     PHPUnit/Extensions/Story/Autoload.php uses an anonymous function which
     requires PHP >= 5.3.0.  Should either make note of this in the description
     or require PHP >= 5.3.0 as a dependency (and notify upstream about a
     package.xml update).



No blockers.

===== APPROVED =====

Comment 4 Remi Collet 2013-04-02 08:51:19 UTC
Thanks for the review.
I will raise the php version after import

New Package SCM Request
=======================
Package Name: php-phpunit-PHPUnit-Story
Short Description: Story extension for PHPUnit to facilitate Behaviour-Driven Development
Owners: remi
Branches: f18 f19 el6
InitialCC:

Comment 5 Gwyn Ciesla 2013-04-02 12:21:34 UTC
Git done (by process-git-requests).

Comment 6 Fedora Update System 2013-04-02 16:05:58 UTC
php-phpunit-PHPUnit-Story-1.0.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-phpunit-PHPUnit-Story-1.0.1-1.el6

Comment 7 Fedora Update System 2013-04-02 16:06:21 UTC
php-phpunit-PHPUnit-Story-1.0.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/php-phpunit-PHPUnit-Story-1.0.1-1.fc18

Comment 8 Fedora Update System 2013-04-03 02:00:43 UTC
php-phpunit-PHPUnit-Story-1.0.1-1.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 9 Fedora Update System 2013-04-11 23:21:12 UTC
php-phpunit-PHPUnit-Story-1.0.1-1.fc18 has been pushed to the Fedora 18 stable repository.

Comment 10 Fedora Update System 2013-04-17 21:48:26 UTC
php-phpunit-PHPUnit-Story-1.0.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.