Bug 950017

Summary: Unable to use LOG_EMERG level in Sys::Syslog
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: perlAssignee: Marcela Mašláňová <mmaslano>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 18CC: cweyl, iarnell, jplesnik, kasal, lkundrak, lzachar, mkyral, mmaslano, perl-devel, ppisar, psabata, rc040203, tcallawa
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: perl-5.16.3-269.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 949927 Environment:
Last Closed: 2013-05-02 13:12:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 950057    
Bug Blocks: 956263, 956264    

Description Petr Pisar 2013-04-09 13:14:43 UTC
+++ This bug was initially created as a clone of Bug #949927 +++

Description of problem:

Level LOG_EMERG seems to be not recognized as valid level for syslog calls.

Other levels "LOG_ALERT LOG_CRIT LOG_ERR LOG_WARNING LOG_NOTICE LOG_INFO" were accepted and produced messages. LOG_DEBUG was accepted as valid level too.

Version-Release number of selected component (if applicable):
perl-5.16.2-[...]

Steps to Reproduce:
1. perl -e 'use Sys::Syslog; syslog(LOG_EMERG, "emergency")'
  
Actual results:
syslog: level must be given at -e line 1.

Expected results:
"emergency" message written

[...]
--- Additional comment from RHEL Product and Program Management on 2013-04-09 10:02:47 GMT ---

This bugzilla has Keywords: Regression or TestBlocker.

Since no regressions or test blockers are allowed between releases,
it is also being [proposed|marked] as a blocker for this release.

Please resolve ASAP.

--- Additional comment from Petr Pisar on 2013-04-09 13:08:53 GMT ---

Thanks for the report. It has been fixed in Sys-Syslog-0.31 <http://cpansearch.perl.org/src/SAPER/Sys-Syslog-0.31/Changes> which has not yet been merged into stable perl release.

I will sub-package Sys-Syslog from perl and package latest release from CPAN which contains the fix.
----

All perl 5.16 releases are affected, F≥18 are affected.

Comment 1 Petr Pisar 2013-04-10 11:52:43 UTC
Fixed with perl-5.16.3-269.fc20 and perl-Sys-Syslog-0.32-1.fc20 in F20.

Comment 2 Fedora Update System 2013-04-11 12:34:39 UTC
perl-5.16.3-262.fc19, perl-Sys-Syslog-0.32-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-5.16.3-262.fc19,perl-Sys-Syslog-0.32-1.fc19

Comment 3 Fedora Update System 2013-04-11 12:38:55 UTC
perl-5.16.3-242.fc18, perl-Sys-Syslog-0.32-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-5.16.3-242.fc18,perl-Sys-Syslog-0.32-1.fc18

Comment 4 Fedora Update System 2013-04-20 19:15:30 UTC
perl-5.16.3-262.fc19, perl-Sys-Syslog-0.32-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Petr Pisar 2013-04-24 15:39:55 UTC
*** Bug 956257 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2013-04-25 00:45:15 UTC
perl-5.16.3-242.fc18, perl-Sys-Syslog-0.32-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.