Bug 950426

Summary: Change requires to python-django14
Product: [Fedora] Fedora Reporter: Matthias Runge <mrunge>
Component: eclipse-pydevAssignee: Alexander Kurtakov <akurtako>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: akurtako, jjohnstn, nathaniel, overholt, swagiaal
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-10 11:55:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 950469    

Description Matthias Runge 2013-04-10 08:47:12 UTC
I see eclipse-pydev requires Django.

We renamed Django to python-django about a year ago. Now we're updating python-django to Django-1.5, which might break packages requiring Django. WRT to eclipse-pydev, I'm simply unsure, as it doesn't really require a special Django version to work, right?

If you want to stick at Django-1.4, we have a compat-package; then please change the requirement from
Requires: Django 
to
Requires: python-django14

Comment 1 Alexander Kurtakov 2013-04-10 11:55:33 UTC
Switched to python-django in http://pkgs.fedoraproject.org/cgit/eclipse-pydev.git/commit/?id=1a77d464e9013a1a633f16e9bf6a20b6d1135ffd . This is just a convenience Requires as pydev has a django wizard and it's easy if we make sure user has it already installed. I prefer to stay away from compat packages as much as possible :).