Bug 951015

Summary: packstack NTP error
Product: [Fedora] Fedora EPEL Reporter: Nux <nux>
Component: openstack-packstackAssignee: Derek Higgins <derekh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: el6CC: derekh, Jan.van.Eldik, mmagr, p, sandro
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-11 11:10:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Nux 2013-04-11 10:57:41 UTC
Description of problem:
When running packstack and having provided an NTP server address it fails with:
Could not evaluate: undefined method `[]=' for nil:NilClass

Full log here:
http://paste.fedoraproject.org/7185/67762713/

Worth mentioning ntp was up and running already when packstack was installed/run.

Version-Release number of selected component (if applicable):
Version     : 2013.1.1       
Release     : 0.4.dev538.el6 


How reproducible:
always

Steps to Reproduce:
1. install packstack
2. generate answer file and specify ntp server
3. run
  
Actual results:
it exits with errors

Expected results:
the installation succeeds

Additional info:

Comment 1 Martin Magr 2013-04-11 11:10:12 UTC
This is problem of puppet and not packstack. Please use puppet-2.6.18-2.1 from grizzly side repo: http://repos.fedorapeople.org/repos/openstack/openstack-grizzly/

*** This bug has been marked as a duplicate of bug 908655 ***