Bug 952390

Summary: No text visible in main window when using qtwebkit-2.3
Product: [Fedora] Fedora Reporter: tbuchanan
Component: bibletimeAssignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 18CC: dakingun, rdieter
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-04 22:23:09 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description tbuchanan 2013-04-15 16:42:02 EDT
Description of problem:No text visible in main window of bibletime.


Version-Release number of selected component (if applicable):bibletime.x86_64 0:2.9.1-3.fc18


How reproducible:no longer works


Steps to Reproduce:
1.uninstall
2.install
3.try to run -- program runs but no bible/commentary text visible in main window
  
Actual results:
no text visible in main window.  seems to flash visible but disappears

Expected results:
See text visible in main window.

Additional info:
Not sure of exact dates but was working mid February 2013.  Noticed wasn't working April 3, 2013.  Xiphos works on same system.  KDE 4.10.2  Will provide additional info if needed.
Comment 1 Rex Dieter 2013-04-18 07:59:20 EDT
rpm -q qtwebkit

please.
Comment 2 Rex Dieter 2013-04-18 08:54:14 EDT
If using qtwebkit-2.3, seems to be this issue.  Additional references,

http://www.crosswire.org/forums/mvnforum/viewthread_thread,1349
https://kororaproject.org/forums/topic/bibletime-2-9-1-and-skype-4-1/
Comment 3 tbuchanan 2013-04-18 08:55:34 EDT
[root@localhost ~]# rpm -q qtwebkit
qtwebkit-2.3.0-1.fc18.x86_64
qtwebkit-2.3.0-1.fc18.i686
Comment 4 Rex Dieter 2013-04-18 08:58:13 EDT
thanks, updating summary.
Comment 5 Rex Dieter 2013-04-18 23:11:56 EDT
I can confirm that upstream master branch 2.10.0_dev snapshot does not exhibit this problem.  I'll try to determine if it's possible to indentify the fix(es) to backport.
Comment 6 Rex Dieter 2013-04-19 00:07:50 EDT
Darn, looked over all commits since 2.9.1 (a lot), tried a few, but was unable to identify which ones help.
Comment 7 Rex Dieter 2013-04-19 08:54:56 EDT
Not to be defeated... :)  started bisecting this morning and found the magic commit  (below).  Doing a little more testing, will commit fix shortly (hopefully).



From fa3625f7b85f6ab5510914ab97e8ea231c252175 Mon Sep 17 00:00:00 2001
From: Gary Holmlund <gary@holmlundg.(none)>
Date: Sun, 16 Dec 2012 18:30:14 -0800
Subject: [PATCH 091/133] Fix moveToAnchor for Qt5

---
 src/frontend/display/bthtmlreaddisplay.cpp | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/src/frontend/display/bthtmlreaddisplay.cpp b/src/frontend/display/bthtmlreaddisplay.cpp
index 5cb69fb..433cec4 100644
--- a/src/frontend/display/bthtmlreaddisplay.cpp
+++ b/src/frontend/display/bthtmlreaddisplay.cpp
@@ -247,7 +247,11 @@ void BtHtmlReadDisplay::selectAll() {

 // Scroll QWebView to the correct location as specified by the anchor
 void BtHtmlReadDisplay::moveToAnchor( const QString& anchor ) {
+#if QT_VERSION >= 0x040700
+    mainFrame()->scrollToAnchor(anchor);
+#else
     slotGoToAnchor(anchor);
+#endif
 }

 // Scroll the QWebView to the correct location specified by anchor
-- 
1.8.1.4
Comment 8 Fedora Update System 2013-04-19 09:19:20 EDT
bibletime-2.9.1-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/bibletime-2.9.1-6.fc19
Comment 9 Rex Dieter 2013-04-19 09:20:45 EDT
confirmed, Deji, would you mind if I issued updates for f17/f18 too?
Comment 10 tbuchanan 2013-04-19 09:42:42 EDT
I rebuilt the srpm from comment 8 and installed and verified that it now works.  Thank you very much for your time and skills.
Comment 11 Fedora Update System 2013-04-19 12:52:09 EDT
Package bibletime-2.9.1-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bibletime-2.9.1-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6105/bibletime-2.9.1-6.fc19
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-04-22 23:35:45 EDT
bibletime-2.9.1-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Rex Dieter 2013-04-26 08:08:57 EDT
heard no objections to comment #10, so moving forward with f17/f18 updates now too
Comment 14 Fedora Update System 2013-04-26 08:35:50 EDT
bibletime-2.9.1-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bibletime-2.9.1-6.fc18
Comment 15 Fedora Update System 2013-04-26 08:38:45 EDT
bibletime-2.9.1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/bibletime-2.9.1-6.fc17
Comment 16 Fedora Update System 2013-04-26 20:17:34 EDT
Package bibletime-2.9.1-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bibletime-2.9.1-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6771/bibletime-2.9.1-6.fc18
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-05-04 22:23:11 EDT
bibletime-2.9.1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-05-04 22:23:21 EDT
bibletime-2.9.1-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.