Bug 953327

Summary: Wesnoth crashes on startup
Product: [Fedora] Fedora Reporter: Ben Boeckel <mathstuf>
Component: wesnothAssignee: Gwyn Ciesla <gwync>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bruno, gwync
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-04-24 15:10:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ben Boeckel 2013-04-18 00:15:00 UTC
Description of problem:
Crashes when starting the game.

#0  __memcpy_ssse3_back () at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:1578
#1  0x0000000000a28c70 in write_key_val_visitor::operator()(t_string const&) const ()
#2  0x0000000000a28ea1 in write_key_val(std::ostream&, std::string const&, config::attribute_value const&, unsigned int, std::string&) ()
#3  0x0000000000a291eb in write_internal(config const&, std::ostream&, std::string&, unsigned long) ()
#4  0x0000000000a29249 in write_internal(config const&, std::ostream&, std::string&, unsigned long) ()
#5  0x0000000000a29372 in write(std::ostream&, config const&, unsigned int) ()
#6  0x000000000074c2d1 in game_config::config_cache::write_file(std::string, config const&) ()
#7  0x00000000007511e9 in game_config::config_cache::read_cache(std::string const&, config&) ()
#8  0x000000000075246b in game_config::config_cache::load_configs(std::string const&, config&) ()
#9  0x000000000048399b in game_controller::load_game_cfg(bool) ()
#10 0x0000000000484ccc in game_controller::init_config(bool) ()
#11 0x00000000004491a9 in do_gameloop(int, char**) ()
#12 0x000000000042c2e4 in main ()

Version-Release number of selected component (if applicable):
wesnoth-1.10.6-1.fc20.x86_64

How reproducible:
Always.

Comment 1 Ben Boeckel 2013-04-18 03:36:43 UTC
Filed upstream. https://gna.org/bugs/index.php?20742

Comment 2 Ben Boeckel 2013-04-24 03:55:30 UTC
Looks like a change is available here[1]. I haven't tested it yet.

[1]http://forums.wesnoth.org/viewtopic.php?f=4&t=38017&p=544425#p544366

Comment 3 Gwyn Ciesla 2013-04-24 12:51:13 UTC
Thanks.  I'll get this patched.  Does it crash on f19 or just rawhide?  Seems OK on f18.

Comment 4 Ben Boeckel 2013-04-24 14:59:44 UTC
I've only tested Rawhide.

Comment 5 Gwyn Ciesla 2013-04-24 15:10:21 UTC
Ok, I'll build it for f19, just to be on the safe side.

Comment 6 Fedora Update System 2013-04-24 16:20:16 UTC
wesnoth-1.10.6-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wesnoth-1.10.6-2.fc19

Comment 7 Ben Boeckel 2013-04-25 00:14:40 UTC
Actually, if it's working on 18, then it's probably a change in GCC 4.8.0 (the forum mentioned undefined behavior), so F19 is wise to do as well. Does no one else play Wesnoth on their development machines? :P

Comment 8 Bruno Wolff III 2013-04-25 02:42:20 UTC
Once in a while I do. But I spend most of my Fedora game time playing Colossus.

Comment 9 Gwyn Ciesla 2013-04-25 11:18:26 UTC
I do my development an gaming on my laptop, which is f18-ish, with lots of f19 and f20 bits for testing. :)

Comment 10 Fedora Update System 2013-04-25 15:57:54 UTC
wesnoth-1.10.6-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wesnoth-1.10.6-3.fc19

Comment 11 Ben Boeckel 2013-04-27 20:08:52 UTC
Works on Rawhide at least. Thanks!

(In reply to comment #8)
> But I spend most of my Fedora game time playing Colossus.

Interesting. When I played Titan with actual cardboard and plastic, I just wanted to play Wesnoth instead :) .

Comment 12 Fedora Update System 2013-04-30 04:45:57 UTC
wesnoth-1.10.6-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.