Bug 956583

Summary: No IP addresses found, cannot continue installation - but networking is up
Product: [Fedora] Fedora Reporter: Dan Horák <dan>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: anaconda-maint-list, awilliam, g.kaviyarasu, jonathan, jstodola, mkolman, rvykydal, sbueno, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: s390x   
OS: Unspecified   
Whiteboard:
Fixed In Version: anaconda-19.23-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-30 01:32:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 467765    
Attachments:
Description Flags
syslog
none
anaconda.log
none
ifcfg.log
none
packaging.log
none
program.log
none
storage.log
none
vncserver.log none

Description Dan Horák 2013-04-25 09:12:42 UTC
Anaconda thinks there is no network, but networking is up and I can connect with ssh after this error is thrown.

...
         Starting firewalld - dynamic firewall daemon...   
         Starting Terminate Plymouth Boot Screen...   
         Starting Wait for Plymouth Boot Screen to Quit...   
         Starting System Logging Service...   
[ [32m  OK   [0m] Started System Logging Service.   
anaconda[1124]: Starting installer, one moment... 
anaconda[1124]: 09:01:39 No IP addresses found, cannot continue installation. 


Version-Release number of selected component (if applicable):
anaconda-19.21-1.fc19

How reproducible:
100%

Comment 1 Dan Horák 2013-04-25 09:18:30 UTC
also VNC is running and I can connect and continue with installation, logs will follow

Comment 2 Dan Horák 2013-04-25 09:46:45 UTC
Created attachment 739758 [details]
syslog

Comment 3 Dan Horák 2013-04-25 09:47:06 UTC
Created attachment 739759 [details]
anaconda.log

Comment 4 Dan Horák 2013-04-25 09:47:11 UTC
Created attachment 739760 [details]
ifcfg.log

Comment 5 Dan Horák 2013-04-25 09:47:16 UTC
Created attachment 739761 [details]
packaging.log

Comment 6 Dan Horák 2013-04-25 09:47:23 UTC
Created attachment 739762 [details]
program.log

Comment 7 Dan Horák 2013-04-25 09:47:29 UTC
Created attachment 739763 [details]
storage.log

Comment 8 Dan Horák 2013-04-25 09:47:35 UTC
Created attachment 739764 [details]
vncserver.log

Comment 9 Radek Vykydal 2013-04-25 11:47:43 UTC
Patch sent for review, you can use this updates image that should fix the issue:

http://rvykydal.fedorapeople.org/updates.activated_devs.img

Comment 10 Jan Stodola 2013-04-25 13:36:36 UTC
The updates image works fine.

Comment 11 Adam Williamson 2013-05-13 16:08:06 UTC
This is marked as being in anaconda 19.23. Beta TC3 had 19.24 and TC4 19.25; could you check with one of those builds and confirm that it works? If so we can close this bug, as 19.25 is stable already.

Comment 12 Adam Williamson 2013-05-30 01:32:00 UTC
welp, if no-one wants to test, and the updates.img was tested, let's just call this good and close it. Re-open if you find it's still a problem. Thanks!