Bug 957435

Summary: [virtio-win][netkvm]Winxp guest is very slowly with netkvm driver installed while restarting/installing third-party software from network
Product: Red Hat Enterprise Linux 6 Reporter: Min Deng <mdeng>
Component: virtio-winAssignee: Yan Vugenfirer <yvugenfi>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.5CC: acathrow, bcao, bsarathy, dfleytma, juzhang, kzhang, lnovich, michen, qzhang
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Interrupt can arrive during device shutdown. Consequence: Interrupt storm on the guest. The guest is hanging. Fix: Disable interrupts and synchronise device shutdown with DIRQL of the device. Result: Device shutdown cannot cause guest hangs anymore.
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-22 00:11:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 912926    
Bug Blocks:    

Description Min Deng 2013-04-28 07:08:12 UTC
Description of problem:
   It is very simple and common scenario as it's a must when QE submit jobs to HCK.One winxp guest needs two nics for netkvm whql - one is rtl8139 another is virtio-nic.After installing virtio netkvm driver into the guest even if very basic actions such as restarting&installing HCK client became more slowly than before.It took QE's more time to finish the configuration.All became slowly,especially to install HCK client.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-59

How reproducible:
3 times 
Steps to Reproduce:
1./usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=winxp-0724.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=01:42:45:36:24:51,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet2,mac=00:24:23:43:51:33,bus=pci.0,addr=0x6 -uuid 6cdaa4e5-1a10-48a9-9009-5c509acc62df -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2012-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 ...
2.install virtio netkvm driver
3.restart/do some actions.such as install HCK client.
  
Actual results:
It took much more time than before.
Expected results:
Don't take much time as usual.


Additional info:it seemed that the guest wasn't slowly if remove virtio nic from guest.

Comment 3 Dmitry Fleytman 2013-05-12 10:57:54 UTC
Fix for this issue is the same as BZ#912926.
Please, verify.

Comment 4 guo jiang 2013-05-16 03:24:14 UTC
I encountered the same problem: WinXP guest became so slowly after installing virtio netkvm driver.Almost can not install HCK client.

How reproducible:
5 times
Step to Reproduce:
1.usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=winxp-0724.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:12:24:2a:3e:23,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet2,mac=00:31:a3:33:e2:4a,bus=pci.0,addr=0x6 -uuid 5bd58aae-e261-4e41-8a96-8ad12901bbc5 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-winxp-32-nic1,server,nowait -mon chardev=111a,mode=readline -spice port=5931,disable-ticketing -vga qxl -name winxp-32-s2-60-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 

2.install netkvm driver download from
  http://download.devel.redhat.com/brewroot/work/tasks/4727/5744727/virtio-win-prewhql-0.1.zip

3.Change computer name and add domain env.

4.restart and install HCK client

Actual results:
After restarting, can not use mouse. It took much more time than before.
Expected results:
mouse is ok. Don't take much time as usual.

Comment 5 guo jiang 2013-05-16 07:03:26 UTC
Packages:

    * Red Hat Enterprise Linux Server release 6.4 (Santiago)
    * kernel-2.6.32-369.el6.x86_64
    * qemu-kvm-rhev-0.12.1.2-2.359.el6.x86_64
    * virtio-win-prewhql-0.1-60
    * spice-server-0.12.0-12.el6.x86_64
    * seabios-0.6.1.2-27.el6.x86_64
    * vgabios-0.6b-3.7.el6.noarch

Comment 6 Min Deng 2013-05-23 02:32:28 UTC
Hi Yan,
   QE re-test it via build 61,Windows XP guest became normally and all the settings are smoothly.So the bug has been fixed,thanks 

Best regards,
Min

Comment 7 Mike Cao 2013-05-28 11:03:26 UTC
Move status to VERIFIED according to comment #6

Comment 13 errata-xmlrpc 2013-11-22 00:11:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html