Bug 957658

Summary: Permissions are wrong on /var/run/zabbix/zabbix_server.pid
Product: [Fedora] Fedora Reporter: Trever Adams <trever>
Component: zabbixAssignee: Dan Horák <dan>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 18CC: brett.lentz, dan, nelsonab, volker27
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-07 15:48:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Trever Adams 2013-04-29 08:21:06 UTC
Description of problem:
zabbix_server [867]: cannot create PID file [/var/run/zabbix/zabbix_server.pid]: [13] Permission denied

zabbix_agent can access the file. zabbix_server is setup to run as zabbixsrv, which most of the configuration files are setup for, this causes the above error.

drwxr-xr-x.  2 zabbix   zabbix     60 Apr 29 02:17 zabbix


Version-Release number of selected component (if applicable):
zabbix-2.0.5-1.fc18.x86_64
zabbix-agent-2.0.5-1.fc18.x86_64
zabbix-server-2.0.5-1.fc18.x86_64
zabbix-server-pgsql-2.0.5-1.fc18.x86_64
zabbix-web-2.0.5-1.fc18.noarch
zabbix-web-pgsql-2.0.5-1.fc18.noarch

Comment 1 Trever Adams 2013-05-03 04:26:20 UTC
Ok, I think I have figured out more of what is going on.

It doesn't seem to be failing to start because of the log or pid permission problem.

It is because /usr/lib/systemd/system/zabbix-server-pgsql.service

has the following line:
ExecStart=/usr/sbin/zabbix_server

It should be either the following, or zabbix-server-pgsql should be setting up a symlink:

ExecStart=/usr/sbin/zabbix_server_pgsql

The permissions are still messed up. tmpfiles.d doesn't seem to be able to do beyond basic owner,group,world modes so I cannot suggest a forced adding of a posix user for zabbixsrv.

Any reason for both zabbix and zabbixsrv users? If so, then maybe they should have different run and log directories.

Comment 2 Trever Adams 2013-05-03 04:30:41 UTC
Sorry, I take that back about the symlink. I removed the zabbix-server and zabbix-server-pgsql packages, reinstalled, the symlinks are right. It is the permissions.

It appears that if you set the owner to zabbixsrv and group to zabbix for the log and run directory, things work.

Comment 3 Volker Fröhlich 2013-05-07 15:48:07 UTC

*** This bug has been marked as a duplicate of bug 904041 ***