Bug 958338

Summary: smtp: does not support plain
Product: [Fedora] Fedora Reporter: Ankur Sinha (FranciscoD) <sanjay.ankur>
Component: gnome-online-accountsAssignee: Debarshi Ray <debarshir>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: bnocera, debarshir, samuel-rhbugs, xranix
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-02-03 14:21:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ankur Sinha (FranciscoD) 2013-05-01 01:31:11 UTC
Description of problem:
goa gives me an error when I try to add my imap/smtp account: 'server does not support PLAIN", probably the authentication method.

Version-Release number of selected component (if applicable):
gnome-online-accounts-3.8.1-1.fc19.x86_64

How reproducible:
All

Steps to Reproduce:
1. try adding imap/smtp account via goa
2.
3.
  
Actual results:
Fails

Expected results:
Should work

Additional info:
Can add it using evolution. Seems to require the "LOGIN" authentication method.

Comment 1 Ankur Sinha (FranciscoD) 2013-05-02 09:21:15 UTC
Clarifying, what I mean is that goa only seems to provide the "PLAIN" authentication method while the server requires a "LOGIN" authentication method.

Comment 2 Debarshi Ray 2013-06-19 12:43:08 UTC
Thanks for the bug report. Sorry that it fell through the cracks.

Is it possible to have a test account on this server? LOGIN was not implemented because all the servers that I had access to supported PLAIN, so having access to a LOGIN-only setup would be very useful for testing.

Comment 3 Ankur Sinha (FranciscoD) 2013-06-23 00:39:00 UTC
Hi Debarshi,

Unfortunately, I don't think I can get you a test account on this server. It's my university's email service (@student.uts.edu.au) and they won't create an account for testing purposes :(

Would it be possible to maybe refer to the implementation in evolution and pull it over to g-o-a? I can test stuff for you, but yeah, it won't be as convenient.

Thanks,
Warm regards,
Ankur

Comment 4 Xra 2013-09-11 09:14:38 UTC
Hello, 

I have the same error/problem. I can setup a test account on my server (ssl+tls+login).

Let me know privately at walter.pircali (at) widata.it.


bye

Comment 5 Debarshi Ray 2013-11-07 11:23:30 UTC
(In reply to Xra from comment #4)
> Hello, 
> 
> I have the same error/problem. I can setup a test account on my server
> (ssl+tls+login).
> 
> Let me know privately at walter.pircali (at) widata.it.

Thanks a lot for giving me the test account.

Comment 6 Debarshi Ray 2013-12-11 17:44:27 UTC
Patches for AUTH LOGIN support are on the upstream bug. Testing is appreciated.

Now Evolution needs to be taught how to detect and handle these accounts.

Lets continue discussing this feature on the upstream bug.