Bug 958395

Summary: Bogus error message from 'fedpkg clone'
Product: [Fedora] Fedora Reporter: David Woodhouse <dwmw2>
Component: fedpkgAssignee: Dennis Gilmore <dennis>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: alonbl, bblaskov, berrange, dan, dennis, dmalcolm, dridi.boukelmoune, fedora, jpazdziora, kdudka, marcandre.lureau, mattdm, nalimilan, ohadlevy, pbabinca, rhbugs, rjones, tomspur, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1033804 (view as bug list) Environment:
Last Closed: 2014-09-26 16:27:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1033804    
Attachments:
Description Flags
Fix log message when cert is missing none

Description David Woodhouse 2013-05-01 10:01:44 UTC
$  fedpkg clone -B evolution-ews
Could not execute clone: not all arguments converted during string formatting


Hm, wtf?

getcwd("/home/dwmw2/fedora", 1024)      = 19
access("/home/dwmw2/.fedora.cert", R_OK) = -1 ENOENT (No such file or directory)
write(2, "Could not execute clone: not all"..., 78Could not execute clone: not all arguments converted during string formatting
) = 78

Copying .fedora.cert into place from another machine makes things work.

I shouldn't need to use strace to work out what went wrong. The error message shouldn't actually bear some relationship to the problem!

Comment 1 Dan Horák 2013-05-20 09:31:43 UTC
using "fedpkg clone -a foo" also workarounds the problem

Comment 2 Daniel Berrangé 2013-08-05 11:30:18 UTC
Created attachment 782754 [details]
Fix log message when cert is missing

This patch fixes the missing format specifier in the log message when the certificate is missing. Of course we still can't clone the repo, but at least we don't get a python exception, so we stand a chance of identifying the real problem by running 'fedpkg -v clone foo'.

Comment 3 Alon Bar-Lev 2013-09-23 20:24:41 UTC
Fix:

/usr/lib/python2.7/site-packages/pyrpkg/rhpkg/__init__.py
--- @529 Commands.load_user
         except Exception, e:
             self.log.debug('Could not get kerberos details, falling back to '
-                           'default method: %s' % e)
+                           'default method: ' % e)
             super(Commands, self).load_user()
---

Comment 4 Dave Malcolm 2013-11-22 19:42:58 UTC
Note that the patches in comments 2 and 3 address two different bugs.

Comment 5 Dave Malcolm 2013-11-22 19:44:00 UTC
(In reply to Dave Malcolm from comment #4)
> Note that the patches in comments 2 and 3 address two different bugs.

Two different root causes, I should say.  Both root causes can manifest as the incomprehensible error message from comment #0.

Comment 7 Milan Bouchet-Valat 2013-12-16 14:42:40 UTC
Confirmed here. I had to Google for the error message and find this bug to understand what was the problem.