This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 959702

Summary: glassfish-servelet-api is required in F19
Product: [Fedora] Fedora Reporter: gil cattaneo <puntogil>
Component: glassfish-servlet-apiAssignee: David Xie <davidx>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: davidx, java-sig-commits, mizdebsk
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glassfish-servlet-api-3.1.0-1.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-14 21:00:11 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 859114    

Description gil cattaneo 2013-05-04 18:05:45 EDT
Description of problem:
for some projects (e.g. Grizzly) glassfish-servelet-api is required also in f18 and f19
please can import in these stable branch?

with jboss or tomcat apis (3.0) build fails
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.5.1:compile (default-compile) on project grizzly-http-servlet: Compilation failure: Compilation failure:
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/HttpServletRequestImpl.java:[89,25] error: cannot find symbol
[ERROR] symbol: class ProtocolHandler
[ERROR] location: package javax.servlet.http
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[61,20] error: cannot find symbol
[ERROR] symbol: class ReadListener
[ERROR] location: package javax.servlet
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/HttpServletRequestImpl.java:[1588,24] error: cannot find symbol
[ERROR] symbol: class ProtocolHandler
[ERROR] location: class HttpServletRequestImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[63,20] error: cannot find symbol
[ERROR] symbol: class WriteListener
[ERROR] location: package javax.servlet
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[168,38] error: cannot find symbol
[ERROR] symbol: class ReadListener
[ERROR] location: class ServletInputStreamImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[150,33] error: cannot find symbol
[ERROR] symbol: class WriteListener
[ERROR] location: class ServletOutputStreamImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[168,16] error: cannot find symbol
[ERROR] symbol: class WriteListener
[ERROR] location: class ServletOutputStreamImpl.WriteHandlerImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[170,33] error: cannot find symbol
[ERROR] symbol: class WriteListener
[ERROR] location: class ServletOutputStreamImpl.WriteHandlerImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[178,16] error: cannot find symbol
[ERROR] symbol: class ReadListener
[ERROR] location: class ServletInputStreamImpl.ReadHandlerImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[180,32] error: cannot find symbol
[ERROR] symbol: class ReadListener
[ERROR] location: class ServletInputStreamImpl.ReadHandlerImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/HttpServletRequestImpl.java:[89,25] error: cannot find symbol
[ERROR] symbol: class ProtocolHandler
[ERROR] location: package javax.servlet.http
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[61,20] error: cannot find symbol
[ERROR] symbol: class ReadListener
[ERROR] location: package javax.servlet
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/HttpServletRequestImpl.java:[1588,24] error: cannot find symbol
[ERROR] symbol: class ProtocolHandler
[ERROR] location: class HttpServletRequestImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[63,20] error: cannot find symbol
[ERROR] symbol: class WriteListener
[ERROR] location: package javax.servlet
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[168,38] error: cannot find symbol
[ERROR] symbol: class ReadListener
[ERROR] location: class ServletInputStreamImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[150,33] error: cannot find symbol
[ERROR] symbol: class WriteListener
[ERROR] location: class ServletOutputStreamImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[168,16] error: cannot find symbol
[ERROR] symbol: class WriteListener
[ERROR] location: class ServletOutputStreamImpl.WriteHandlerImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[170,33] error: cannot find symbol
[ERROR] symbol: class WriteListener
[ERROR] location: class ServletOutputStreamImpl.WriteHandlerImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[178,16] error: cannot find symbol
[ERROR] symbol: class ReadListener
[ERROR] location: class ServletInputStreamImpl.ReadHandlerImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[180,32] error: cannot find symbol
[ERROR] symbol: class ReadListener
[ERROR] location: class ServletInputStreamImpl.ReadHandlerImpl
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/HttpServletRequestImpl.java:[302,4] error: method does not override or implement a method from a supertype
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/HttpServletRequestImpl.java:[1587,4] error: method does not override or implement a method from a supertype
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/HttpServletResponseImpl.java:[275,4] error: method does not override or implement a method from a supertype
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[131,4] error: method does not override or implement a method from a supertype
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[139,4] error: method does not override or implement a method from a supertype
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletInputStreamImpl.java:[167,4] error: method does not override or implement a method from a supertype
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[121,4] error: method does not override or implement a method from a supertype
[ERROR] modules/http-servlet/src/main/java/org/glassfish/grizzly/servlet/ServletOutputStreamImpl.java:[149,4] error: method does not override or implement a method from a supertype
[ERROR] -> [Help 1]

Version-Release number of selected component (if applicable):
3.1

How reproducible:
always

Expected results:
import in f18 and f19

Additional info:
Comment 1 Mikolaj Izdebski 2013-05-06 10:20:46 EDT
There may be some problems with adding glassfish-servelet-api to
Fedora 18.  I'm not the one to decide, but there are some things
to be considered:

1) The Maven artifact that glassfish-servlet-api is javax.servlet :
   javax.servlet-api.  The same artifact is also provided by package
   tomcat-servlet-3.0-api.

   In Fedora we generally can't have two versions of the same
   artifacts unless one of them is a compatibility package.  Now the
   question is which package (tomcat or glassfish) should be the
   compat package?  We shouldn't migrate tomcat-servlet-3.0-api
   package because that change could cause massive breakage of
   packages that depend on tomcat-servlet-3.0-api (currently over
   60 packages).

   The only choice is adding glassfish-servlet-api as a compatibility
   package.  This means that merging master to f18 branch is not an
   option.  glassfish-servelet-api would have to be converted to be
   compatibility package and tested as such.

2) The API itself probably is not very useful if there is no
   implementation of that API available.  Is there Servlet 3.1
   implementation available in Fedora 18?

3) Is there any other package besides grizzly that requires the new
   Servlet API?  Why is adding grizzly to Fedora 18 important?
   Can't grizzly just be built for Fedora 20?

4) Stable release is not right place for development and adding new
   packages, especially if they may cause problems.  Fedora Update
   Policy [1] explicitly says that "updates should aim to fix bugs,
   and not introduce features" and "stable releases will not closely
   track the very latest upstream code for all packages. We have
   rawhide for that."

In my opinion glassfish-servelet-api shouldn't be added to Fedora 18.
All development should be done in Fedora 20 (Fedora 19 is after
development freeze now).

[1] https://fedoraproject.org/wiki/Updates_Policy#Philosophy
Comment 2 David Xie 2013-05-06 11:28:02 EDT
Agreed.

Thank you for your explanation, Mikolaj!
Comment 3 Fedora Update System 2013-07-06 12:12:45 EDT
glassfish-servlet-api-3.1.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/glassfish-servlet-api-3.1.0-1.fc19
Comment 4 Fedora Update System 2013-07-06 21:30:06 EDT
Package glassfish-servlet-api-3.1.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glassfish-servlet-api-3.1.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12472/glassfish-servlet-api-3.1.0-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-14 21:00:11 EDT
glassfish-servlet-api-3.1.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.