Bug 959925

Summary: libical-1.0 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: libicalAssignee: Milan Crha <mcrha>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mcrha, rdieter, redhat-bugzilla
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-27 07:11:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
.spec patch to update to libical-1.0 and switch to cmake buildsys
none
libical .spec file patch none

Description Upstream Release Monitoring 2013-05-06 09:01:34 UTC
Latest upstream release: 1.0
Current version in Fedora Rawhide: 0.48
URL: http://sourceforge.net/api/file/index/project-name/freeassociation/mtime/desc/limit/100/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Milan Crha 2013-05-06 12:39:37 UTC
I would update only Rawhide (aka to be Fedora 20) repository, just in case this release would add any unexpected issues.

Comment 2 Milan Crha 2013-05-15 18:21:31 UTC
It currently doesn't build on my machine, with error described here:
http://sourceforge.net/mailarchive/forum.php?thread_name=1368641868.13455.7.camel%40localhost&forum_name=freeassociation-devel

Comment 3 Rex Dieter 2013-05-15 18:32:48 UTC
I can help switch to using cmake

Comment 4 Rex Dieter 2013-05-15 19:13:09 UTC
Looks like (re)running:

autoreconf -f -i

(in %prep, prior to %build), is enough to fix things.  Though that doesn't fix the upstream error of not bumping sonames in autotools buildsys:
http://sourceforge.net/mailarchive/message.php?msg_id=30844310

I'm ok with either approach, though since it would appear that Allen has intentions of dropping autotools buildsys in the near future anyway, switching to cmake sooner rather than later makes more sense to me.

Comment 5 Rex Dieter 2013-05-15 19:13:52 UTC
Created attachment 748463 [details]
.spec patch to update to libical-1.0 and switch to cmake buildsys

Comment 6 Milan Crha 2013-05-16 07:56:47 UTC
Thanks for the help. I agree with the switch to cmake buildsys, it's better to do it rather sooner than later. I see you also did a cleanup to the .spec, to remove unnecessary lines.

I also see that I did my 'cmake' changes incorrectly, totally caused by my lack of knowledge of the 'cmake'. Thanks again, I'll test it and probably commit for rawhide.

Comment 7 Milan Crha 2013-05-16 11:04:16 UTC
I can build evolution packages against the libical 1.0 without any issue, thus I sent a notice to devel list and will update rawhide at the end of the next week. I'll check about the 0.48 workaround for escaping, which seems to be obsolete and doing only trouble here, but it might be an easy change in the CalDAV provider.

Comment 8 Milan Crha 2013-05-16 12:33:04 UTC
I found one significant change, libical 1.0 saves timezone with whole change history, which is for me between 1945 to 2037. Apart of the file being too large, thus the network traffic is affected when it comes to CalDAV and such, then the servers (like Google or Zimbra) has an issue to understand such timezones. I sent an email to libical forum, awaiting their opinion:
http://sourceforge.net/mailarchive/forum.php?thread_name=1368705037.32533.11.camel%40localhost&forum_name=freeassociation-devel
http://sourceforge.net/mailarchive/forum.php?thread_name=1368706327.480.11.camel%40localhost&forum_name=freeassociation-devel

Comment 9 Milan Crha 2013-05-24 14:59:32 UTC
Created attachment 752725 [details]
libical .spec file patch

Slightly polished libical patch from Rex (still with his credits).

I thought I have commit rights for libical, but I do not, I cannot commit
the change to master (Fedora 20) :-/

Rex, could you do that, please? I'll ask for commit rights meanwhile (and for the future).

Comment 10 Rex Dieter 2013-05-24 15:46:45 UTC
OK, can do.

Comment 11 Rex Dieter 2013-05-24 15:51:11 UTC
and, subsequent rebuilds (at least):

$ repoquery --repoid=rawhide-source --archlist=src --whatrequires libical-devel

asterisk-0:11.4.0-1.fc20.src
evolution-data-server-0:3.9.1-1.fc20.src
gnokii-0:0.6.31-5.fc20.src
kdepimlibs-0:4.10.3-1.fc20.src
obexd-1:0.46-4.fc19.src
openchange-0:2.0-1.fc19.src
osmo-0:0.2.12-0.5.svn924.fc20.src
syncevolution-1:1.3.99.3-1.fc20.src
zarafa-0:7.0.13-1.fc19.src

Comment 12 Milan Crha 2013-05-27 07:11:31 UTC
Thanks Rex. I see you updated rawhide, thus I'm closing this bug.