Bug 962065
| Summary: | selinux-policy(-targeted)-3.11.1-94 does not allow Postfix to start | ||
|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | James Wilkinson <bugzilla> |
| Component: | selinux-policy-targeted | Assignee: | Miroslav Grepl <mgrepl> |
| Status: | CLOSED DUPLICATE | QA Contact: | Ben Levenson <benl> |
| Severity: | unspecified | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 18 | CC: | dwalsh, redhat-bugzilla, wfp5p |
| Target Milestone: | --- | Keywords: | Reopened |
| Target Release: | --- | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | selinux-policy-3.11.1-95.fc18 | Doc Type: | Bug Fix |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2013-05-22 03:08:56 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Files mentioned are /var/spool/postfix/pid/(unix.cleanup,inet.smtp), FWIW. This problem also exists in selinux-policy-3.12.1-42 on F19 alpha. #============= postfix_cleanup_t ============== #!!!! This avc is allowed in the current policy allow postfix_cleanup_t postfix_var_run_t:file create; #============= postfix_smtpd_t ============== #!!!! This avc is allowed in the current policy allow postfix_smtpd_t postfix_var_run_t:file create; # rpm -Uvh http://kojipkgs.fedoraproject.org//packages/selinux-policy/3.12.1/43.fc19/noarch/selinux-policy-3.12.1-43.fc19.noarch.rpm http://kojipkgs.fedoraproject.org//packages/selinux-policy/3.12.1/43.fc19/noarch/selinux-policy-targeted-3.12.1-43.fc19.noarch.rpm will fix it. Confirmed. The updated selinux policy has fixed it. selinux-policy-3.11.1-95.fc18 has been submitted as an update for Fedora 18. https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-95.fc18 Package selinux-policy-3.11.1-95.fc18: * should fix your issue, * was pushed to the Fedora 18 testing repository, * should be available at your local mirror within two days. Update it with: # su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-95.fc18' as soon as you are able to. Please go to the following url: https://admin.fedoraproject.org/updates/FEDORA-2013-8591/selinux-policy-3.11.1-95.fc18 then log in and leave karma (feedback). selinux-policy-3.11.1-95.fc18 has been pushed to the Fedora 18 stable repository. If problems still persist, please make note of it in this bug report. selinux-policy-3.11.1-95.fc18 does not fix the problem for me. postfix will start with this installed, but it will not accept incoming mail. Incoming mail results in (from /var/log/maillog):
May 21 13:49:40 hastur postfix/smtpd[19580]: fatal: open lock file pid/inet.smtp: cannot create file exclusively: Permission denied
May 21 13:49:41 hastur postfix/master[19287]: warning: process /usr/libexec/postfix/smtpd pid 19580 exit status 1
May 21 13:49:41 hastur postfix/master[19287]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
and from the audit.log:
type=AVC msg=audit(1369158580.309:160): avc: denied { create } for pid=19580 comm="smtpd" name="inet.smtp" scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file
Yes, it has been fixed in -96.fc18 http://koji.fedoraproject.org/koji/buildinfo?buildID=420279 Should be stable soon. selinux-policy-3.11.1-95.fc18 has been pushed to the Fedora 18 stable repository. If problems still persist, please make note of it in this bug report. *** This bug has been marked as a duplicate of bug 964679 *** |
Description of problem: Postfix won't start with selinux-policy(-targeted)-3.11.1-94. Downgrade to 3.11.1-92, and it will start. Additional info: type=AVC msg=audit(1368276914.665:906): avc: denied { create } for pid=2765 comm="smtpd" name="inet.smtp" scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file type=AVC msg=audit(1368276931.693:907): avc: denied { create } for pid=2773 comm="cleanup" name="unix.cleanup" scontext=system_u:system_r:postfix_cleanup_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file and in /var/log/maillog May 11 13:00:20 faure postfix/smtpd[2590]: fatal: open lock file pid/inet.smtp: cannot create file exclusively: Permission denied May 11 13:00:21 faure postfix/master[2525]: warning: process /usr/libexec/postfix/smtpd pid 2590 exit status 1 May 11 13:00:21 faure postfix/master[2525]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling May 11 13:00:34 faure postfix/cleanup[2591]: fatal: open lock file pid/unix.cleanup: cannot create file exclusively: Permission denied May 11 13:00:35 faure postfix/master[2525]: warning: process /usr/libexec/postfix/cleanup pid 2591 exit status 1 May 11 13:00:35 faure postfix/master[2525]: warning: /usr/libexec/postfix/cleanup: bad command startup -- throttling (Note: times may not exactly match: these show up quite a bit in the logs, once for each time I tried to get it to start.)