Bug 963415

Summary: VSS support for qemu-ga-win
Product: Red Hat Enterprise Linux 6 Reporter: Dave Allan <dallan>
Component: libvirtAssignee: Michal Privoznik <mprivozn>
Status: CLOSED NOTABUG QA Contact: Virtualization Bugs <virt-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 6.5CC: acathrow, areis, bsarathy, dyasny, dyuan, gsun, honzhang, juzhang, michen, mkenneth, mzhan, qzhang, rhod, sluo, tsekiyam, virt-maint, whuang
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 948017 Environment:
Last Closed: 2013-06-27 15:33:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 948017    
Bug Blocks: 896690, 883504    

Description Dave Allan 2013-05-15 18:35:15 UTC
+++ This bug was initially created as a clone of Bug #948017 +++

When performing online backups, applications are not aware of guest-agent freeze/thaw commands and therefore the filesystem may be in an inconsistent state due to pending disk flushes.

For Linux, there's support for guest-agent hooks on freeze/thaw (Bug 911569), which can be used to notify applications (or stop/start daemons). On Windows, the correct way to handle freeze/thaw is using the VSS API.

Some details about VSS:
http://msdn.microsoft.com/en-us/library/windows/desktop/bb968832%28v=vs.85%29.aspx

--- Additional comment from Ademar de Souza Reis Jr. on 2013-05-15 10:04:10 EDT ---

Update: Hitachi is proposing it upstream. Please review the patch and help them get it merged:

http://lists.gnu.org/archive/html/qemu-devel/2013-02/msg01963.html

Comment 2 Michal Privoznik 2013-05-16 08:25:30 UTC
I don't think there's a need fro any libvirt integration. However, I'll keep an eye on this, if something pops up.

Comment 3 Michal Privoznik 2013-06-27 15:33:48 UTC
I don't see any room for libvirt involvement here as I've stated in comment 2. Since then the nature of the bug hasn't changed so I am closing this one. If somebody disagrees please do reopen.