Bug 965111

Summary: wireshark: DoS (infinite loop) in the MySQL dissector (wnpa-sec-2013-30, upstream #8458)
Product: [Other] Security Response Reporter: Jan Lieskovsky <jlieskov>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED DUPLICATE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: huzaifas, jrusnack, jsafrane, phatina, rvokal
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-23 05:36:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 881873, 965942    
Bug Blocks: 965198    

Description Jan Lieskovsky 2013-05-20 12:57:58 UTC
A denial of service flaw was found in the way MySQL dissector of Wireshark, a network traffic analyzer, processed certain MySQL packet capture files. A remote attacker could provide a specially-crafted MySQL packet capture file that, when processed, would lead to denial of service (wireshark executable to enter infinite loop while trying to dissect that file).

Upstream bug report:
[1] https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8458

Reproducer:
[2] https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8458#c1

Upstream patch:
[3] http://anonsvn.wireshark.org/viewvc?view=revision&revision=48894

Comment 1 Huzaifa S. Sidhpurwala 2013-05-22 06:30:32 UTC
Created wireshark tracking bugs for this issue

Affects: fedora-17 [bug 881873]
Affects: fedora-18 [bug 965942]

Comment 3 Huzaifa S. Sidhpurwala 2013-05-22 09:26:37 UTC
Upstream advisory:

http://www.wireshark.org/security/wnpa-sec-2013-30.html

Comment 4 Huzaifa S. Sidhpurwala 2013-05-22 10:21:52 UTC
Statement:

This issue does not affect the version of wireshark as shipped with Red Hat Enterprise Linux 5. This issue affects the version of wireshark as shipped with Red Hat Enterprise Linux 6. The Red Hat Security Response Team has rated this issue as having low security impact, a future update may address this flaw.

Comment 5 Huzaifa S. Sidhpurwala 2013-05-23 05:36:29 UTC

*** This bug has been marked as a duplicate of bug 966331 ***