Bug 966369

Summary: compiz crashes under Xvnc (segmentation fault)
Product: Red Hat Enterprise Linux 6 Reporter: Peter ├ůstrand <astrand>
Component: compizAssignee: Owen Taylor <otaylor>
Status: CLOSED WONTFIX QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.4CC: todoleza, tpelka
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-06 11:17:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Core dump
none
maps
none
backtrace none

Description Peter ├ůstrand 2013-05-23 07:42:47 UTC
Created attachment 752011 [details]
Core dump

Description of problem:
compiz crashes when executed in a Xvnc compiled with composite


Version-Release number of selected component (if applicable):
compiz-gnome-0.8.2-24.el6.x86_64
compiz-0.8.2-24.el6.x86_64


How reproducible:
Launch Xvnc session, compiled with composite. We are using TigerVNC. Start terminal. Execute compiz --replace. Result:

compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Segmentation fault (core dumped)

Core dump attached.

Comment 2 Tomas Dolezal 2013-10-01 13:28:49 UTC
after boot and first log in:
abrt caught it

command: 
compiz --ignore-desktop-hints glib gconf gnomecompat
pkgs:
compiz-0.8.2-24.el6
kernel-2.6.32-419.el6.x86_64

reason: SIGSEGV

Comment 3 Tomas Dolezal 2013-10-10 13:25:50 UTC
Created attachment 810511 [details]
maps

attaching maps from abrt

Comment 4 Tomas Dolezal 2013-10-10 13:26:49 UTC
Created attachment 810513 [details]
backtrace

attaching backtrace from abrt

Comment 6 RHEL Program Management 2013-10-13 23:34:42 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 7 Jan Kurik 2017-12-06 11:17:09 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/