Bug 972727

Summary: Reload Repository not working while a process is running
Product: [Retired] JBoss BPMS Platform 6 Reporter: Zuzana Krejčová <zkrejcov>
Component: Business CentralAssignee: Mauricio Salatino <msalatin>
Status: CLOSED CURRENTRELEASE QA Contact: Zuzana Krejčová <zkrejcov>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.0.0CC: lpetrovi, rzhang
Target Milestone: DR6   
Target Release: 6.0.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-06 20:12:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Zuzana Krejčová 2013-06-10 13:27:08 UTC
Description of problem:
The Process Definition view has a button for reloading repository. If no process instance is running, you might get a short "please wait" pop-up, then you get get notified that process was refreshed from repository.
Once you start an instance of a process, you get that "please wait" pop-up but nothing else - the pop-up won't disappear and the view is inoperable.
The kie-ide needs to be refreshed and the running instances finished or aborted before the reloading works again.


Version-Release number of selected component (if applicable):
BPMS 6, DR5


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Mauricio Salatino 2013-06-24 10:05:44 UTC
Fixed in master and also in beta4