Bug 97683

Summary: 'bold' variants not working
Product: [Retired] Red Hat Raw Hide Reporter: Tim Waugh <twaugh>
Component: urw-fontsAssignee: Ngo Than <than>
Status: CLOSED WORKSFORME QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-23 04:19:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tim Waugh 2003-06-19 06:31:24 EDT
Description of problem:
In Nimbus Roman No 9 L, and URW Bookman, the bold variants are not working.

Version-Release number of selected component (if applicable):
urw-fonts-2.1-1

How reproducible:
100%

Steps to Reproduce:
1. Start OpenOffice.org
2. Start typing
3. Click on the 'bold' button.
4. Resume typing

5. Open nautilus at fonts:///
    
Actual results:
After step 4, no difference in weight is seen.  For other fonts bold is heavier
as it should be.

After step 5, bold variants for the urw fonts are not seen.

Expected results:
Bold is heavier than regular.

Additional info:
Comment 1 Ngo Than 2003-06-20 06:39:29 EDT
i can reproduce it with "Nimbus Roman No 9 L", but "Urw Bookman l" works fine
for me.
Comment 2 Ngo Than 2003-06-20 08:12:20 EDT
it seems that n021024l has wrong Weight. I have fixed this font in 2.1-2. It
should work now.
Comment 3 Tim Waugh 2003-06-21 04:28:53 EDT
That's worse.  Now there's no 'Regular', just bold.
Comment 4 Ngo Than 2003-06-23 04:12:28 EDT
Hmm, it works fine for me both in koffice and oowriter with this 2.1-2 !
which font did you mean here?
Comment 5 Ngo Than 2003-06-23 04:19:26 EDT
it's fixed in 2.1-2
Comment 6 Miloš Komarčević 2003-07-11 08:46:51 EDT
I'm also seeing bold only Nimbus Roman No9 L with 2.1-2, no regular.
This is for example in OOwriter, Mozilla and Gnome font preferences.
Also there seems to be no Bold (i.e. Medium) Italic listed for Nimbus Roman No9 L
in Gnome font preferences.
 
I also have only bold Bookman and Palatino in OOwriter.
Comment 7 Miloš Komarčević 2003-07-27 16:38:53 EDT
And now in 2.1-4.1 Nimbus Roman No9 L regular is fine,
but italic is bolded.