This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 981425

Summary: seamonkey-2.19 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: seamonkeyAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ajschult, caillon+fedoraproject, cfeller, dmitry, gecko-bugs-nobody, kengert
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: seamonkey-2.19-2.el6 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-22 21:08:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
stacktrace opening mail none

Description Upstream Release Monitoring 2013-07-04 12:17:47 EDT
Latest upstream release: 2.19
Current version/release in Fedora Rawhide: 2.17-1.fc20
URL: http://www.seamonkey-project.org/releases/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Fedora Update System 2013-07-09 15:11:22 EDT
seamonkey-2.19-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/seamonkey-2.19-1.el6
Comment 2 Fedora Update System 2013-07-09 15:12:18 EDT
seamonkey-2.19-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/seamonkey-2.19-1.fc19
Comment 3 Fedora Update System 2013-07-09 15:13:19 EDT
seamonkey-2.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/seamonkey-2.19-1.fc18
Comment 4 Fedora Update System 2013-07-09 15:14:12 EDT
seamonkey-2.19-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/seamonkey-2.19-1.fc17
Comment 5 Fedora Update System 2013-07-10 18:06:40 EDT
Package seamonkey-2.19-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing seamonkey-2.19-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-10814/seamonkey-2.19-1.el6
then log in and leave karma (feedback).
Comment 6 Andrew Schultz 2013-07-12 10:53:20 EDT
Created attachment 772755 [details]
stacktrace opening mail

FYI, the seamonkey package for el6 seems unhappy.  For me, mail crashes (stacktrace attached).  It seems nss-related, probably the nss available on el6 is incompatible (stack frames 1-5 are in /usr/lib64/libssl3.so)

The second problem could be related -- the result of any https attempt in the browser is that it prompts me to save the result.

------------------------------------------
You have chosen to open:



  which is a:  BIN file
  from: https://bugzilla.redhat.com

Would you like to save this file?

            Cancel     Save File
-------------------------------------------

Again, I wouldn't be surprised if this is due to nss.
Comment 7 Andrew Schultz 2013-07-12 17:29:57 EDT
I should add that my system has nss-3.14.0.0-12.el6.x86_64

Sadly enough, I rebuilt myself with the bundled nss and continue to have the same problems (mail and https), so it seems things are more complicated than I assumed.

I tried the fedora 19 build (on fedora 19) and it works fine.
Comment 8 Dmitry Butskoy 2013-07-13 09:31:44 EDT
> I rebuilt myself with the bundled nss and continue to have the same problems (mail and https)

Thanks a lot!

Are you sure you actually use the bundled nss at runtime? I mean the presence of "nss*" etc. ".so" files in the /usr/lib64/seamonkey/ directory...
Comment 9 Dmitry Butskoy 2013-07-13 10:01:16 EDT
Does the current el6 version of 2.17.1 OK or not?
Comment 10 Andrew Schultz 2013-07-13 11:19:28 EDT
(In reply to Dmitry Butskoy from comment #8)
> Are you sure you actually use the bundled nss at runtime? I mean the
> presence of "nss*" etc. ".so" files in the /usr/lib64/seamonkey/ directory...

Yes, /usr/lib64/seamonkey includes libnss3.so, libnssckbi.so, libnssdbm3.chk, etc.

./run-mozilla.sh /usr/bin/ldd ./libxul.so | grep libssl
        libssl3.so => ./libssl3.so (0x00007fdff6c80000)

(In reply to Dmitry Butskoy from comment #9)
> Does the current el6 version of 2.17.1 OK or not?

Yes, 2.17.1 works OK.

I rebuilt again with bundled nspr (as well as nss), and that seems to work fine.  https sites work and mail works without crashing.
Comment 11 Dmitry Butskoy 2013-07-13 11:26:57 EDT
Thanks.

Looks like an issue with backporting from "bundled" nspr-4.9.6 to the el6 system's nspr-4.9.2. Something in nspr-4.9.5 or nspr-4.9.6 (seamonkey-2.17.1 "backported" from nspr-4.9.4 to nspr-4.9.2 works).

I'll try to look at this at the nearest time.
Comment 12 Dmitry Butskoy 2013-07-15 11:26:10 EDT
Well,

The problem is changes in nspr's function PR_PushIOLayer()/PR_PopIOLayer(), which were changed between nspr-4.9.2 and nspr-4.9.3 . The new seamonkey-2.19 starts to rely on this new behaviour.

The file "mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp, mentioned in the backtrace, looks like a place for most changes...

I think we can just use the bindled nspr (from seamonkey-2.19 source), since actually nspr has "the same upstream" and is updated fast enough. The nss should be system's, at list while some ecc code (patent encumbered) is stripped etc.
Comment 13 Dmitry Butskoy 2013-07-15 15:42:25 EDT
Try the latest koji build:
http://kojipkgs.fedoraproject.org//packages/seamonkey/2.19/2.el6/
Comment 14 Fedora Update System 2013-07-15 15:59:24 EDT
seamonkey-2.19-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/seamonkey-2.19-2.el6
Comment 15 Andrew Schultz 2013-07-21 13:44:00 EDT
I've been away the past week, but I've tried your latest build (now in epel-testing) and it works great.  mail and https both work fine.

Thanks!
Comment 16 Fedora Update System 2013-07-22 21:08:41 EDT
seamonkey-2.19-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-07-22 21:09:36 EDT
seamonkey-2.19-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-07-22 21:10:33 EDT
seamonkey-2.19-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-08-01 16:33:39 EDT
seamonkey-2.19-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.