Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 985545

Summary: parallel using deprecated perl features
Product: [Fedora] Fedora Reporter: John Ellson <john.ellson>
Component: parallelAssignee: Golo Fuchert <packages>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 19CC: hugh, packages
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: parallel-20130522-2.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-30 13:43:53 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Ellson 2013-07-17 13:40:55 EDT
Description of problem:
The version of "parallel" currently available on fc19 is using deprecated perl features.    The latest build in koji works for me on fc19.  Can it be distributed ASAP please?

It would also be nice to have parallel in the RHEL distributions.
  

Version-Release number of selected component (if applicable):
parallel-20120222-2.fc18.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1.  parallel --gnu ssh {} date ::: localhost
2.
3.

Actual results:
defined(@array) is deprecated at /usr/bin/parallel line 119.
	(Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/parallel line 585.
	(Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/parallel line 631.
	(Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/parallel line 632.
	(Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/parallel line 633.
	(Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/parallel line 666.
	(Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/parallel line 1541.
	(Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/parallel line 1547.
	(Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/parallel line 1553.
	(Maybe you should just omit the defined()?)
Wed Jul 17 13:36:02 EDT 2013


Expected results:
no deprecated messages

Additional info:
http://koji.fedoraproject.org/koji/packageinfo?packageID=12540
Comment 1 Fedora Update System 2013-07-21 08:35:34 EDT
parallel-20130522-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/parallel-20130522-2.fc19
Comment 2 Golo Fuchert 2013-07-21 08:42:35 EDT
Sorry for the inconvenience, I wanted to push this before the release of f19 but was too slow.

In principle it shouldn't be a problem to have this package in RHEL, but I think we will run into the same problem as we did for Fedora [1]. I will contact the moreutils package maintainer for RHEL, but don't expect a fast solution.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=675495
Comment 3 Fedora Update System 2013-07-21 20:27:43 EDT
Package parallel-20130522-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parallel-20130522-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13314/parallel-20130522-2.fc19
then log in and leave karma (feedback).
Comment 4 Golo Fuchert 2013-07-27 17:24:08 EDT
*** Bug 988987 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-07-30 13:43:53 EDT
parallel-20130522-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.