Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 985703

Summary: maven: Update to Eclipse Aether
Product: [Fedora] Fedora Reporter: Mikolaj Izdebski <mizdebsk>
Component: mavenAssignee: Mikolaj Izdebski <mizdebsk>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: akurtako, java-sig-commits, mizdebsk, msrb, sochotni, tradej
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 3.1.0-2 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-25 00:04:34 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 985674, 985689    

Description Mikolaj Izdebski 2013-07-18 01:24:26 EDT
Description of problem:
Package maven currently Requires or BuildRequires aether.

Currently Fedora ships Sonatype Aether, but there are plans to migrate
to Eclipse Aether.  Because Eclipse Aether is incompatible with Sonatype Aether
maven will likely have to be updated or patched.

Version-Release number of selected component (if applicable):
3.0.5-7
Comment 1 Mikolaj Izdebski 2013-07-23 05:11:55 EDT
Fixed in maven-3.1.0-1
Comment 2 Mikolaj Izdebski 2013-07-25 00:04:34 EDT
I believe that this bug is fixed in maven-3.1.0-2,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=436927