Bug 985791

Summary: perl-core does not contain all perl modules
Product: Red Hat Enterprise Linux 6 Reporter: Victor Efimov <victor>
Component: perlAssignee: Jitka Plesnikova <jplesnik>
Status: CLOSED ERRATA QA Contact: Martin Kyral <mkyral>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.4CC: jplesnik, mkyral, ppisar, psabata
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: perl-5.10.1-135.el6 Doc Type: Bug Fix
Doc Text:
Cause: perl-core should requires all of the perl bits and modules in the upstream tarball from perl.org Consequence: Module CGI.pm is missing after the installation of perl-core Fix: Add perl-CGI to perl-core's run-requires Result: The module CGI.pm is on system after the installation of perl-core
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-21 04:41:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Victor Efimov 2013-07-18 09:09:57 UTC
perl-core package has a description "A metapackage which requires all of the perl bits and modules in the upstream tarball from perl.org."

However it's not accurate. It misses CGI.pm

CGI.pm is not listed in dependencies http://pkgs.org/centos-6-rhel-6/centos-rhel-x86_64/perl-core-5.10.1-129.el6.x86_64.rpm.html

And CGI.pm does not get installed after perl-core install

I propose update description for perl-core package and mention that not everything from tarball is installed.

Comment 5 errata-xmlrpc 2013-11-21 04:41:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1534.html