Bug 989209

Summary: remove biosdevname from boot.iso
Product: [Fedora] Fedora Reporter: Michal Hlavinka <mhlavink>
Component: loraxAssignee: Brian Lane <bcl>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: anaconda-maint-list, bcl, dcbw, dshea, g.kaviyarasu, johannbg, jonathan, lnykryn, mhlavink, mkolman, msekleta, plautrba, sbueno, systemd-maint, vanmeeuwen+fedora, vpavlin, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: lorax-21.15-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-02 21:20:50 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michal Hlavinka 2013-07-28 07:23:10 EDT
Description of problem:
I have 4 ethernet NIC. After fresh Fedora 19 installation, the names are as follows:
p2p1
p32p1
p36p1
p37p1
this is also what 'biosdevname -d' shows

BUT names in /etc/sysconfig/network-scripts/ are
ifcfg-enp1s0:NAME=enp1s0
ifcfg-enp2s0:NAME=enp2s0
ifcfg-enp3s0:NAME=enp3s0
ifcfg-enp4s0:NAME=enp4s0

Version-Release number of selected component (if applicable):
NetworkManager-0.9.8.2-8.git20130709.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1.install Fedora 19
2.
3.

Actual results:
difference between NIC name and what NM uses

Expected results:
all names the same

Additional info:
Comment 1 Michal Hlavinka 2013-07-29 06:34:12 EDT
this is caused by biosdevname feature fighting with predictable network names feature.

I guess biosdevname is obsolete now and should not be installed by default.
Comment 2 Dan Williams 2013-07-30 01:16:25 EDT
NM doesn't actually create the files, nor do they get renamed because that causes other problems, and makes people angry that their configuration is getting moved around.

In reality, it's because I don't think the setup environment is running the same logic as the runtime environment for device naming (udev?).

Anaconda team, is this a dracut thing, anaconda thing, or a udev thing?
Comment 3 David Shea 2014-03-13 15:13:52 EDT
(In reply to Dan Williams from comment #2)
> NM doesn't actually create the files, nor do they get renamed because that
> causes other problems, and makes people angry that their configuration is
> getting moved around.
> 
> In reality, it's because I don't think the setup environment is running the
> same logic as the runtime environment for device naming (udev?).
> 
> Anaconda team, is this a dracut thing, anaconda thing, or a udev thing?

udev handles naming network devices.
Comment 4 Lennart Poettering 2014-06-19 14:58:47 EDT
Well, if anaconda still runs biosdevname while installing but not in the final system then the interface names don't match. There's little systemd can do about that.

Please consider removing biosdevname from the anaconda installer. Assigning back.
Comment 5 Brian Lane 2014-06-26 14:15:04 EDT
As far as I can tell we're still using biosdevname in the installed system. dracut has it in the initrd, lorax is installing it into the boot.iso root filesystem and a rawhide minimal install includes it on the target system.

Could the original reporter give this a try with f20 or rawhide?
Comment 6 Michal Hlavinka 2014-06-30 10:03:58 EDT
I've just tried fresh installation of Fedora 20 on 2xNIC machine.
After installation biosdevname was installed.
Devices got names em1 and em2
The same names were used in network-scripts/ifcfg-NIC
Comment 7 Zbigniew Jędrzejewski-Szmek 2014-06-30 11:21:14 EDT
This should be fixed soonish for new installations with https://git.fedorahosted.org/cgit/comps.git/commit/?id=c1d40aae68d5b4d5ec170a82d02ef9a2daf7264d.