Bug 1000119 - [abrt] java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19: __sigtimedwait: Process /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19: __sigtimedwait: Process /us...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:eb4e62c94f9f8059feaf15a4cbb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 14:28 EDT by cuidighth
Modified: 2013-08-23 01:14 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 01:14:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (91.61 KB, text/plain)
2013-08-22 14:28 EDT, cuidighth
no flags Details
File: cgroup (140 bytes, text/plain)
2013-08-22 14:28 EDT, cuidighth
no flags Details
File: core_backtrace (83.97 KB, text/plain)
2013-08-22 14:28 EDT, cuidighth
no flags Details
File: dso_list (14.23 KB, text/plain)
2013-08-22 14:28 EDT, cuidighth
no flags Details
File: environ (1.37 KB, text/plain)
2013-08-22 14:28 EDT, cuidighth
no flags Details
File: hs_err.log (132.80 KB, text/plain)
2013-08-22 14:29 EDT, cuidighth
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-22 14:29 EDT, cuidighth
no flags Details
File: maps (99.54 KB, text/plain)
2013-08-22 14:29 EDT, cuidighth
no flags Details
File: open_fds (20.24 KB, text/plain)
2013-08-22 14:29 EDT, cuidighth
no flags Details
File: proc_pid_status (934 bytes, text/plain)
2013-08-22 14:29 EDT, cuidighth
no flags Details
File: var_log_messages (282 bytes, text/plain)
2013-08-22 14:29 EDT, cuidighth
no flags Details

  None (edit)
Description cuidighth 2013-08-22 14:28:31 EDT
Version-Release number of selected component:
java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/bin/java -jar /home/mikko.lehtisalo/Downloads/ApacheDirectoryStudio-linux-x86_64-2.0.0.v20130628/plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar -os linux -ws gtk -arch x86_64 -showsplash -launcher /home/mikko.lehtisalo/Downloads/ApacheDirectoryStudio-linux-x86_64-2.0.0.v20130628/ApacheDirectoryStudio -name ApacheDirectoryStudio --launcher.library /home/mikko.lehtisalo/Downloads/ApacheDirectoryStudio-linux-x86_64-2.0.0.v20130628/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20120522-1813/eclipse_1502.so -startup /home/mikko.lehtisalo/Downloads/ApacheDirectoryStudio-linux-x86_64-2.0.0.v20130628/plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar --launcher.overrideVmargs -exitdata 50758005 -vm /usr/bin/java -vmargs -jar /home/mikko.lehtisalo/Downloads/ApacheDirectoryStudio-linux-x86_64-2.0.0.v20130628/plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
crash_function: __sigtimedwait
executable:     /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19.x86_64/jre/bin/java
kernel:         3.10.7-200.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (1 frames)
 #0 __sigtimedwait at ../sysdeps/unix/sysv/linux/sigtimedwait.c:75
Comment 1 cuidighth 2013-08-22 14:28:39 EDT
Created attachment 789298 [details]
File: backtrace
Comment 2 cuidighth 2013-08-22 14:28:43 EDT
Created attachment 789299 [details]
File: cgroup
Comment 3 cuidighth 2013-08-22 14:28:48 EDT
Created attachment 789300 [details]
File: core_backtrace
Comment 4 cuidighth 2013-08-22 14:28:53 EDT
Created attachment 789301 [details]
File: dso_list
Comment 5 cuidighth 2013-08-22 14:28:57 EDT
Created attachment 789302 [details]
File: environ
Comment 6 cuidighth 2013-08-22 14:29:05 EDT
Created attachment 789303 [details]
File: hs_err.log
Comment 7 cuidighth 2013-08-22 14:29:09 EDT
Created attachment 789304 [details]
File: limits
Comment 8 cuidighth 2013-08-22 14:29:15 EDT
Created attachment 789305 [details]
File: maps
Comment 9 cuidighth 2013-08-22 14:29:24 EDT
Created attachment 789306 [details]
File: open_fds
Comment 10 cuidighth 2013-08-22 14:29:28 EDT
Created attachment 789307 [details]
File: proc_pid_status
Comment 11 cuidighth 2013-08-22 14:29:33 EDT
Created attachment 789308 [details]
File: var_log_messages
Comment 12 Deepak Bhole 2013-08-22 14:36:32 EDT
Looks like an SWT JNI issue based on hs_err. Re-assigning to Eclipse.
Comment 13 Alexander Kurtakov 2013-08-23 01:14:35 EDT
This bug is due to ApacheDirectoryStudio shipping with old swt that can't work with newer versions of webkitgtk. I would recommend installing eclipse swt (`yum install eclipse-swt`) and copy /usr/lib64/eclipse/swt.jar to ApacheDirectoryStudio with name matching the swt file there and try again. Also please open a bug against ApacheDirectoryStudio asking them to update to newer swt version where critical bugs like that one are fixed.
As there is not much more we can do as ApacheDirectorystudio is not built by fedora, I'm closing the bug now.

Note You need to log in before you can comment on or make changes to this bug.