Bug 1000195 - tg3 BCM5705M link drops during boot
tg3 BCM5705M link drops during boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-22 18:17 EDT by Orion Poplawski
Modified: 2014-11-20 18:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-20 18:56:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-08-22 18:17:48 EDT
Description of problem:

I'm unable to install Fedora 17 through rawhide on a Latitude X300 with a:

02:05.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet [14e4:165d] (rev 01)

network card.  During boot link drops around tg3 initialization/link up attempt and cannot be revived.

Actually appears to drop at this line:

IPv6: ADDRCONF(NETDEV_UP): em1: link is not ready

Disabling ipv6 removes that line, but link still drops around that time.

Removing and re-adding the tg3 module in the dracut shell does not bring it back.

Disconnecting/reconnecting the cable doesn't help.

Appears to work fine under Windows XP.

Tried setting rd.blacklist=tg3 - no effect.

Set tg3.tg3_debug=-1 but no new messages.

Version-Release number of selected component (if applicable):
3.11.0-0.rc6.git1.2.fc21

How reproducible:
Every time
Comment 1 Orion Poplawski 2014-11-20 18:56:54 EST
Finally seems to be mostly working again.

Note You need to log in before you can comment on or make changes to this bug.