Bug 1000307 - cannot install RHEL5.10 host with customized xfs partition
cannot install RHEL5.10 host with customized xfs partition
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.10
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 03:01 EDT by Eryu Guan
Modified: 2013-08-23 11:53 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 11:53:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample job xml (1.43 KB, text/plain)
2013-08-23 03:01 EDT, Eryu Guan
no flags Details

  None (edit)
Description Eryu Guan 2013-08-23 03:01:27 EDT
Created attachment 789490 [details]
sample job xml

Description of problem:
I have the following partition in my job xml, and all my jobs aborted

	<partitions>
		<partition fs="xfs" name="/mnt/testarea" size="10" type="part"/>
	</partitions>

+---------------+ Exception Occurred +---------------+      
|                                                    |       
| Traceback (most recent call first):              ^ |       
|   File "/usr/lib64/python2.4/subprocess.py",     # |       
| line 996, in _execute_child                      : |       
|     raise child_exception                        : |       
|   File "/usr/lib64/python2.4/subprocess.py",     : |       
| line 550, in __init__                            : |        
|     errread, errwrite)                           : |        
|   File "/usr/lib/anaconda/iutil.py", line 60,    : |        
| in execWithRedirect                              : |        
|     stderr=stderr, preexec_fn=chroot, cwd=root)  : |        
|   File "/usr/lib/anaconda/fsset.py", line 472,   : |        
| in formatDevice                                  v |        
|                                                    |        
|         +----+                  +-------+          |        
|         | OK |                  | Debug |          |        
|         +----+                  +-------+          |        
|                                                    |        
|                                                    |        
+----------------------------------------------------+        

If I change fs type to ext* other than xfs, OS can be installed.

Version-Release number of selected component (if applicable):
0.14.1

How reproducible:
always

Steps to Reproduce:
1. add the partitions from description in job xml and submit a job to install RHEL5.10 hosts
2. I upload a sample job xml
3.

Actual results:


Expected results:


Additional info:
Not sure if it's really a beaker bug, correct me if I was wrong
Comment 2 Nick Coghlan 2013-08-23 03:17:56 EDT
The traceback suggests a possible anaconda bug, particularly since the ext* filesystems are working correctly.

Is there any further information in the log files?
Comment 5 Dan Callaghan 2013-08-23 04:05:56 EDT
(In reply to Eryu Guan from comment #0)
> 	<partitions>
> 		<partition fs="xfs" name="/mnt/testarea" size="10" type="part"/>
> 	</partitions>

Beaker produced in the kickstart:

    part /boot --size 200 --recommended --asprimary
    part / --size 1024 --grow
    part swap --recommended
    part /mnt/testarea --size=10240 --fstype xfs

which looks fine to me.

> +---------------+ Exception Occurred +---------------+      
> |                                                    |       
> | Traceback (most recent call first):              ^ |       
> |   File "/usr/lib64/python2.4/subprocess.py",     # |       
> | line 996, in _execute_child                      : |       
> |     raise child_exception                        : |       
> |   File "/usr/lib64/python2.4/subprocess.py",     : |       
> | line 550, in __init__                            : |        
> |     errread, errwrite)                           : |        
> |   File "/usr/lib/anaconda/iutil.py", line 60,    : |        
> | in execWithRedirect                              : |        
> |     stderr=stderr, preexec_fn=chroot, cwd=root)  : |        
> |   File "/usr/lib/anaconda/fsset.py", line 472,   : |        
> | in formatDevice                                  v |        
> |                                                    |        
> |         +----+                  +-------+          |        
> |         | OK |                  | Debug |          |        
> |         +----+                  +-------+          |        
> |                                                    |        
> |                                                    |        
> +----------------------------------------------------+        

The complete exception is in anaconda.log:

04:44:09 CRITICAL: Traceback (most recent call first):
  File "/usr/lib64/python2.4/subprocess.py", line 996, in _execute_child
    raise child_exception
  File "/usr/lib64/python2.4/subprocess.py", line 550, in __init__
    errread, errwrite)
  File "/usr/lib/anaconda/iutil.py", line 60, in execWithRedirect
    stderr=stderr, preexec_fn=chroot, cwd=root)
  File "/usr/lib/anaconda/fsset.py", line 472, in formatDevice
    stderr = "/dev/tty5")
  File "/usr/lib/anaconda/fsset.py", line 1914, in formatEntry
    entry.fsystem.formatDevice(entry, self.progressWindow, chroot)
  File "/usr/lib/anaconda/fsset.py", line 1991, in makeFilesystems
    self.formatEntry(entry, chroot)
  File "/usr/lib/anaconda/packages.py", line 162, in turnOnFilesystems
    anaconda.id.fsset.makeFilesystems (anaconda.rootPath)
  File "/usr/lib/anaconda/dispatch.py", line 207, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 728, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 980, in ?
    anaconda.intf.run(anaconda)
RuntimeError: /usr/sbin/mkfs.xfs can not be run

I don't think this is Beaker's fault, re-assigning to Anaconda.
Comment 6 David Shea 2013-08-23 11:53:32 EDT
Hi everyone,

XFS is available in RHEL5 only as an add-on product. The XFS utilities can be installed on a RHEL-5 system, but XFS is not available during installation. The interactive installer does not allow partitions to be created with XFS, but the kickstart install puts more of the verification onus on the kickstart writer, so it doesn't check for whether the filesystem picked is actually supported.

Anyway, I guess re-open the bug if this is something that needs to be disabled in beaker.

Note You need to log in before you can comment on or make changes to this bug.