Bug 1000362 - sudo + sssd + local user sends e-mail to administrator
sudo + sssd + local user sends e-mail to administrator
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 05:35 EDT by Lukas Slebodnik
Modified: 2013-12-20 21:24 EST (History)
4 users (show)

See Also:
Fixed In Version: sudo-1.8.6p7-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-20 21:24:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2013-08-23 05:35:38 EDT
Description of problem:
When sudo is used with sssd and a local user runs sudo, an e-mail is sent to administrator, because sssd does not support sudo rules for local users. It is not an error, only noise.

Version-Release number of selected component (if applicable):
shel$ rpm -q sudo
sudo-1.8.6p7-1.fc19.x86_64

Steps to Reproduce:
1. configure sudo to use sssd as data source ('sudoers: files sss' in /etc/nsswitch.conf
2. run sssd
3. log in as local user
4. run 'sudo -l' as local user
  
Actual results:
E-mail is sent to administrator:
"problem with defaults entries ; TTY=pts/2 ; PWD=/home/fuero"

Expected results:
No e-mail is sent.

Additional info:
The bug has already been fixed in RHEL6.4
https://bugzilla.redhat.com/show_bug.cgi?id=879633

This bug is in fedora 19, thus it have to be in RHEL7.
Comment 1 Alexander Bokovoy 2013-12-18 17:10:10 EST
This bug prevents use of sudo rules with SSSD against FreeIPA in Fedora 19.

David, please fix it asap. No reaction in 4 months is a shame.
Comment 2 Alexander Bokovoy 2013-12-19 07:27:23 EST
I've used patch from 1.8.8 from rawhide, added a fix from RHEL6.4 mentioned in the bug 879633 and built this scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=6314141 for Fedora 19.

Feel free to reuse, we need a fix in Fedora 19.
Comment 3 Fedora Update System 2013-12-19 13:35:36 EST
sudo-1.8.6p7-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sudo-1.8.6p7-2.fc19
Comment 4 Fedora Update System 2013-12-20 21:24:54 EST
sudo-1.8.6p7-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.